aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in5
-rw-r--r--driver.c17
-rw-r--r--etrn.c10
-rw-r--r--fetchmail.c8
-rw-r--r--pop3.c4
5 files changed, 21 insertions, 23 deletions
diff --git a/Makefile.in b/Makefile.in
index 5a9094ee..0b47756b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,8 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=3.9
-PL=1
+VERS=3.9.1
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -30,7 +29,7 @@ RANLIB = @RANLIB@
# See also `config.h'.
DEFS = @DEFS@
# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
-defines = -DRELEASE_ID=\"$(VERS)\" -DPATCHLEVEL=\"$(PL)\" $(DEFS)
+defines = -DRELEASE_ID=\"$(VERS)\" $(DEFS)
# If your system needs extra libraries loaded in, define them here.
LOADLIBS = @LIBS@ @LEXLIB@
diff --git a/driver.c b/driver.c
index 9045fcc7..04b28a67 100644
--- a/driver.c
+++ b/driver.c
@@ -695,7 +695,7 @@ char *realname; /* real name of host */
if (!sinkfp)
{
- error(0, 0, "MDA open failed");
+ error(0, -1, "MDA open failed");
return(PS_IOERR);
}
@@ -710,7 +710,7 @@ char *realname; /* real name of host */
if (!ctl->mda && ((sinkfp = smtp_open(ctl)) == NULL))
{
free_str_list(&xmit_names);
- error(0, 0, "SMTP connect to %s failed",
+ error(0, -1, "SMTP connect to %s failed",
ctl->smtphost ? ctl->smtphost : "localhost");
if (return_path)
free(return_path);
@@ -767,7 +767,7 @@ char *realname; /* real name of host */
int smtperr = atoi(smtp_response);
if (smtperr >= 400)
- error(0, 0, "SMTP error: %s", smtp_response);
+ error(0, -1, "SMTP error: %s", smtp_response);
/*
* There's one problem with this flow of control;
@@ -817,7 +817,7 @@ char *realname; /* real name of host */
default: /* retry with invoking user's address */
if (SMTP_from(sinkfp, user, options) != SM_OK)
{
- error(0,0,"SMTP error: %s", smtp_response);
+ error(0, -1, "SMTP error: %s", smtp_response);
if (return_path)
free(return_path);
return(PS_SMTP); /* should never happen */
@@ -1117,7 +1117,7 @@ const char *canonical; /* server name */
free (ticket);
if (rem != KSUCCESS)
{
- error(0, 0, "kerberos error %s", (krb_get_err_text (rem)));
+ error(0, -1, "kerberos error %s", (krb_get_err_text (rem)));
return (PS_ERROR);
}
return (0);
@@ -1136,7 +1136,7 @@ const struct method *proto; /* protocol method table */
#ifndef KERBEROS_V4
if (ctl->server.authenticate == A_KERBEROS)
{
- error(0, 0, "Kerberos support not linked.");
+ error(0, -1, "Kerberos support not linked.");
return(PS_ERROR);
}
#endif /* KERBEROS_V4 */
@@ -1311,7 +1311,7 @@ const struct method *proto; /* protocol method table */
ok = PS_AUTHFAIL;
if (ok != 0)
{
- error(0, 0, "Authorization failure on %s@%s",
+ error(0, -1, "Authorization failure on %s@%s",
ctl->remotename,
realname);
goto cleanUp;
@@ -1543,7 +1543,7 @@ const struct method *proto; /* protocol method table */
}
if (ok==PS_SOCKET || ok==PS_AUTHFAIL || ok==PS_SYNTAX || ok==PS_IOERR
|| ok==PS_ERROR || ok==PS_PROTOCOL || ok==PS_SMTP)
- error(0, 0, "%s error while fetching from %s", msg, ctl->server.names->id);
+ error(0, -1, "%s error while fetching from %s", msg, ctl->server.names->id);
closeUp:
signal(SIGALRM, sigsave);
@@ -1676,4 +1676,3 @@ va_dcl
}
/* driver.c ends here */
-
diff --git a/etrn.c b/etrn.c
index 1e44656e..a2254c79 100644
--- a/etrn.c
+++ b/etrn.c
@@ -66,23 +66,23 @@ static int etrn_getrange(FILE *sockfp, struct query *ctl, int*countp, int*newp)
break;
case 458: /* Unable to queue messages for node <x> */
- error(0, 0, "Unable to queue messages for node %s", ctl->smtphost);
+ error(0, -1, "Unable to queue messages for node %s", ctl->smtphost);
return(PS_PROTOCOL);
case 459: /* Node <x> not allowed: <reason> */
- error(0, 0, "Node %s not allowed: %s", ctl->smtphost, buf);
+ error(0, -1, "Node %s not allowed: %s", ctl->smtphost, buf);
return(PS_AUTHFAIL);
case 500: /* Syntax Error */
- error(0, 0, "ETRN syntax error");
+ error(0, -1, "ETRN syntax error");
return(PS_PROTOCOL);
case 501: /* Syntax Error in Parameters */
- error(0, 0, "ETRN syntax error in parameters");
+ error(0, -1, "ETRN syntax error in parameters");
return(PS_PROTOCOL);
default:
- error(0, 0, "Unknown ETRN error");
+ error(0, -1, "Unknown ETRN error %d", atoi(buf));
return(PS_PROTOCOL);
}
diff --git a/fetchmail.c b/fetchmail.c
index ea5888ce..700b9bab 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -155,7 +155,7 @@ int main (int argc, char **argv)
setvbuf(stdout, NULL, _IOLBF, POPBUFSIZE);
if (versioninfo)
- printf("This is fetchmail release %s pl %s\n", RELEASE_ID, PATCHLEVEL);
+ printf("This is fetchmail release %s\n", RELEASE_ID);
/* avoid parsing the config file if all we're doing is killing a daemon */
if (!quitmode)
@@ -330,7 +330,7 @@ int main (int argc, char **argv)
{
if (!nodetach)
daemonize(logfile, termhook);
- error( 0, 0, "starting fetchmail %s.%s daemon ", RELEASE_ID, PATCHLEVEL);
+ error( 0, 0, "starting fetchmail %s daemon ", RELEASE_ID);
}
/* beyond here we don't want more than one fetchmail running per user */
@@ -738,8 +738,8 @@ static int query_host(struct query *ctl)
time_t now;
time(&now);
- fprintf(stderr, "fetchmail: %s.%s querying %s (protocol %s) at %s",
- RELEASE_ID, PATCHLEVEL,
+ fprintf(stderr, "fetchmail: %s querying %s (protocol %s) at %s",
+ RELEASE_ID,
ctl->server.names->id, showproto(ctl->server.protocol), ctime(&now));
}
switch (ctl->server.protocol) {
diff --git a/pop3.c b/pop3.c
index 4a232a1a..01bae347 100644
--- a/pop3.c
+++ b/pop3.c
@@ -71,7 +71,7 @@ int pop3_getauth(FILE *sockfp, struct query *ctl, char *greeting)
for (start = greeting; *start != 0 && *start != '<'; start++)
continue;
if (*start == 0) {
- error(0, 0, "Required APOP timestamp not found in greeting");
+ error(0, -1, "Required APOP timestamp not found in greeting");
return(PS_AUTHFAIL);
}
@@ -79,7 +79,7 @@ int pop3_getauth(FILE *sockfp, struct query *ctl, char *greeting)
for (end = start; *end != 0 && *end != '>'; end++)
continue;
if (*end == 0 || end == start + 1) {
- error(0, 0, "Timestamp syntax error in greeting");
+ error(0, -1, "Timestamp syntax error in greeting");
return(PS_AUTHFAIL);
}
else