aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL5
-rw-r--r--NEWS1
-rw-r--r--configure.in7
3 files changed, 11 insertions, 2 deletions
diff --git a/INSTALL b/INSTALL
index eaafb6f8..dbb5d14b 100644
--- a/INSTALL
+++ b/INSTALL
@@ -13,8 +13,9 @@ running fetchmail.
1. USEFUL THINGS TO INSTALL FIRST
If you want support for RFC1938-compliant one-time passwords, you'll
-need to install Craig Metz's OPIE libraries first. The fetchmail
-build process will detect them and configure appropriately.
+need to install Craig Metz's OPIE libraries first. Then configure
+with --enable-OPIE, and fetchmail build process will detect them and
+compile appropriately.
Note: there is no point in doing this unless your server is
OTP-enabled. To test this, telnet to the server port and give it
diff --git a/NEWS b/NEWS
index 88906918..ca1bb27c 100644
--- a/NEWS
+++ b/NEWS
@@ -21,6 +21,7 @@
------------------------------------------------------------------------------
fetchmail-4.0.5 ()
* Increased %o in the Lex source to cope with Ultrix lex.
+* RPMs are now built with --without-OPIE to avoid validation problems.
fetchmail-4.0.4 (Mon Jul 28 23:38:20 EDT 1997)
* Overhauled the build machinery.
diff --git a/configure.in b/configure.in
index 4ec6cdb0..f74123f3 100644
--- a/configure.in
+++ b/configure.in
@@ -125,6 +125,13 @@ AC_ARG_ENABLE(POP2,
[with_POP2=no])
test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+### use option --enable-OPIE to compile in the OPIE support
+AC_ARG_ENABLE(OPIE,
+ [ --enable-OPIE compile in OPIE protocol support (obsolete)],
+ [with_OPIE=$enableval],
+ [with_OPIE=no])
+test "$with_OPIE" = "yes" && AC_DEFINE(OPIE_ENABLE)
+
### use option --with-kerberos=DIR to point at a Kerberos directory
AC_ARG_WITH(kerberos,
[ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])