aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4ec49388..c1138ae0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -775,7 +775,9 @@ then
PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
LDFLAGS="$LDFLAGS -L$with_ssl/lib"
- #LIBS="$LIBS -lssl -lcrypto" # replaced by AC_LIB_LINKFLAGS below
+ AC_LIB_LINKFLAGS([crypto])
+ AC_LIB_LINKFLAGS([ssl], [crypto])
+ LIBS="$LIBS $LIBSSL $LIBCRYPTO"
dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
found=0