aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.in2
-rw-r--r--fetchmail.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a3935000..9e40d26c 100644
--- a/configure.in
+++ b/configure.in
@@ -70,7 +70,7 @@ dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
AC_SUBST(EXTRAOBJ)
-AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search)
+AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search herror)
dnl AC_FUNC_SETVBUF_REVERSED
diff --git a/fetchmail.c b/fetchmail.c
index 539da0e7..83ce10ef 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -343,8 +343,10 @@ int main (int argc, char **argv)
if (errno == ENETUNREACH)
break; /* go to sleep */
}
+#ifdef HAVE_HERROR /* NEXTSTEP doesn't */
else
herror("DNS error");
+#endif /* HAVE_HERROR */
continue;
}
else