aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS3
-rw-r--r--driver.c3
-rw-r--r--fetchmail.man16
4 files changed, 13 insertions, 11 deletions
diff --git a/Makefile.in b/Makefile.in
index cae12205..84783d5f 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,7 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=4.4.0
+VERS=4.3.6
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 8a003856..497088d8 100644
--- a/NEWS
+++ b/NEWS
@@ -33,8 +33,9 @@ fetchmail-4.4.0 ()
logging directory.
* Close pipe to MDA when we get a nonresponse timeout. This should
prevent MDA zombies from piling up when we have errors.
+* Treat Netscape's "X-Mozilla-Status" lines like "Status:" lines.
-There are 271 people on fetchmail-friends and 119 on fetchmail-announce.
+There are 269 people on fetchmail-friends and 123 on fetchmail-announce.
fetchmail-4.3.5 (Mon Dec 15 06:07:08 EST 1997)
* Added Kent Robotti's fetchsetup configuration script.
diff --git a/driver.c b/driver.c
index e9c5aedb..43cebf25 100644
--- a/driver.c
+++ b/driver.c
@@ -687,7 +687,8 @@ int num; /* index of message */
* unconditionally. Nonempty ones get chucked if the user
* turns on the dropstatus flag.
*/
- if (!strncasecmp(line, "Status:", 7))
+ if (!strncasecmp(line, "Status:", 7)
+ || !strncasecmp(line, "X-Mozilla-Status:", 7))
{
char *cp;
diff --git a/fetchmail.man b/fetchmail.man
index 5a749ef3..5f31a017 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -888,7 +888,7 @@ pass8bits \& T{
Force BODY=8BITMIME to ESMTP listener
T}
dropstatus \& T{
-Strip Status lines out of incoming mail
+Strip Status and X-Mozilla-Status lines out of incoming mail
T}
no keep -K T{
Delete seen messages from server (default)
@@ -1065,13 +1065,13 @@ is forced to declare BODY=8BITMIME to any ESMTP-capable listener. If
the listener is 8-bit-clean (as all the major ones now are) the right
thing will probably result.
.PP
-The `dropstatus' option controls whether nonempty Status lines are
-retained in fetched mail (the default) or discarded. Retaining them
-allows your MUA to see what messages (if any) were marked seen on the
-client. On the other hand, it can confuse some new-mail notifiers,
-which assume that anything with a Status line in it has been seen.
-(Note: the empty Status lines inserted by some buggy POP servers are
-unconditionally discarded.)
+The `dropstatus' option controls whether nonempty Status and
+X-Mozilla-Status lines are retained in fetched mail (the default) or
+discarded. Retaining them allows your MUA to see what messages (if
+any) were marked seen on the server. On the other hand, it can
+confuse some new-mail notifiers, which assume that anything with a
+Status line in it has been seen. (Note: the empty Status lines
+inserted by some buggy POP servers are unconditionally discarded.)
.PP
.SS Miscellaneous Run Control Options
The words `here' and `there' have useful English-like