aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in6
-rw-r--r--NEWS1
-rw-r--r--configure.in27
3 files changed, 23 insertions, 11 deletions
diff --git a/Makefile.in b/Makefile.in
index e98fbba5..42e2b86e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -212,13 +212,13 @@ mostlyclean: clean
# one below is unnecessary and causes problems with cross-platform builds.
${srcdir}/configure: configure.in aclocal.m4
- cd ${srcdir} && autoconf
+ cd ${srcdir} && @AUTOCONF@
# autoheader might not change config.h.in, so touch a stamp file.
${srcdir}/config.h.in: stamp-h.in
${srcdir}/stamp-h.in: configure.in aclocal.m4 acconfig.h # config.h.top config.h.bot
- cd ${srcdir} # && autoheader
+ cd ${srcdir} # && @AUTOHEADER@
echo timestamp> ${srcdir}/stamp-h.in
config.h: stamp-h
@@ -232,7 +232,7 @@ config.status: configure
./config.status --recheck
$(srcdir)/aclocal.m4: configure.in
- cd $(srcdir) && aclocal
+ cd $(srcdir) && @ACLOCAL@
# This tells versions [3.59,3.63) of GNU make not to export all variables.
.NOEXPORT:
diff --git a/NEWS b/NEWS
index 09755591..4c50d093 100644
--- a/NEWS
+++ b/NEWS
@@ -4,6 +4,7 @@
* Fix insecure tempfile creation bug in fetchmailconf, thanks
to Colin Phipps <cph@cph.demon.co.uk>
+* Configure cleanup from HMH.
* Documentation refresh.
fetchmail-5.7.3 (Sun Mar 11 17:01:56 EST 2001), 20323 lines:
diff --git a/configure.in b/configure.in
index c1cbe481..8d07ee66 100644
--- a/configure.in
+++ b/configure.in
@@ -11,6 +11,25 @@ dnl We want these before the checks, so the checks can modify their values.
test -z "$CFLAGS" && CFLAGS="-O" AC_SUBST(CFLAGS)
test -z "$LDFLAGS" && LDFLAGS=AC_SUBST(LDFLAGS)
+PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
+VERSION=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
+AM_INIT_AUTOMAKE("$PACKAGE", "$VERSION")
+
+dnl Map autoconf, autoheader and aclocal to (/bin/true) if they are
+dnl not available in the system, so as not to cause problems in
+dnl Makefile.in. Be sure to fix this hack if we start supporting
+dnl automake (Makefile.am).
+
+if test -z "$AUTOCONF" ; then
+ AUTOCONF=true
+fi
+if test -z "$ACLOCAL" ; then
+ ACLOCAL=true
+fi
+if test -z "$AUTOHEADER" ; then
+ AUTOHEADER=true
+fi
+
AC_CANONICAL_HOST
AC_PROG_CC
AC_PROG_INSTALL
@@ -36,14 +55,6 @@ AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
-PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
-AC_SUBST(PACKAGE)
-
-VERSION=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
-AC_SUBST(VERSION)
-
# Check for LynxOS special case: -lbsd needed (at least on 2.3.0) and -s
# not working.
if test `uname` = "LynxOS"