aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS4
-rw-r--r--configure.ac12
2 files changed, 13 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index b0269ff6..03cf276d 100644
--- a/NEWS
+++ b/NEWS
@@ -58,6 +58,10 @@ fetchmail-6.3.18 (not yet released):
* Fetchmail would warn about insecure SSL/TLS connections even if a matching
--sslfingerprint was specified. This is an omission from a SSL usability
change made in 6.3.17. Fixes Debian Bug#580796 reported by Roland Stigge.
+* Fetchmail 6.3.15, 6.3.16, and 6.3.17 would pick up libmd5 to obtain MD5*
+ functions. This fails if, for instance, libmd5.so was installed as part of
+ libwww on machines where long isn't 32-bits. Fixes Gentoo Bug #319283,
+ reported - including the crucial hint to libwww - by Karl Hakimian.
# KNOWN BUGS AND WORKAROUNDS:
(this section floats upwards through the NEWS file so it stays with the
diff --git a/configure.ac b/configure.ac
index 2ff315f1..943eb3e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,9 +171,15 @@ dnl [LIBS="$LIBS -lintl"])
AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat])
-AC_SEARCH_LIBS(MD5Init, [md5 md], [],
- [AC_LIBSOURCE(md5c.c)
- EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"])
+have_md5=no
+if test "$ac_cv_header_md5_h" != no ; then
+ AC_SEARCH_LIBS(MD5Init, [md], [have_md5=yes])
+fi
+
+if test "$have_md5" != yes ; then
+ AC_LIBSOURCE(md5c.c)
+ EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"
+fi
AC_CHECK_FUNC(getopt_long, [],
[AC_LIBSOURCES([getopt.c, getopt1.c])