aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in4
-rw-r--r--NEWS6
-rw-r--r--configure.in4
-rw-r--r--fetchmail-FAQ.html26
-rwxr-xr-xfetchmailconf14
-rw-r--r--imap.c20
6 files changed, 40 insertions, 34 deletions
diff --git a/Makefile.in b/Makefile.in
index 49a4c132..65730bb1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.6.2
+VERSION = 5.6.3
SUBDIRS = @POSUB@
@@ -148,7 +148,7 @@ netrc: netrc.c xmalloc.o error.o
$(CC) -DSTANDALONE -DHAVE_CONFIG_H -I. -g -o $@ $^
.c.o:
- $(CC) $(defines) -c $(CPFLAGS) -I$(srcdir) $(CEFLAGS) $(CFLAGS) $<
+ $(CC) $(defines) -c $(CPFLAGS) -I. -I$(srcdir) $(CEFLAGS) $(CFLAGS) $<
# For some losing Unix makes.
SHELL = /bin/sh
diff --git a/NEWS b/NEWS
index 10028c32..0cc5301a 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,12 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* VPATH build fixed (thanks to Harry McGavran).
+* Danny O'Brien's patch allowing preauth and idle to work together.
+* Fixed a bug in configure.in that was resulting in KERBEROS_IV being
+ set when it should not have been (several reports).
+* FAQ change: mailing lists have moved to MailMan.
+
fetchmail-5.6.2 (Fri Jan 5 16:45:47 EST 2001), 19744 lines:
* Dave Bodenstab's fix for the lockfile re-exec problem.
diff --git a/configure.in b/configure.in
index 393e7add..1d8dcdd5 100644
--- a/configure.in
+++ b/configure.in
@@ -413,18 +413,18 @@ then
done
elif test -n "$with_kerberos" -a "$with_kerberos" != "no"
then
- AC_DEFINE(KERBEROS_V4)
+ AC_DEFINE(KERBEROS_V4)
CEFLAGS="$CEFLAGS -I$with_kerberos/include"
LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib"
LIBS="$LIBS -lkrb -ldes"
else
if test "$with_kerberos" != "no"
then
- AC_DEFINE(KERBEROS_V4)
for dir in /usr/kerberos /usr/kerberosIV /usr/athena
do
if test -f "$dir/include/krb.h"
then
+ AC_DEFINE(KERBEROS_V4)
CEFLAGS="$CEFLAGS -I$dir/include"
LDEFLAGS="$LDEFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index 701e81f6..791915d3 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/01/15 07:28:51 $
+<td width="30%" align=right>$Date: 2001/02/07 00:47:40 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -323,17 +323,11 @@ very accommodating about good ideas.<p>
<h2><a name="G5">G5. Is there a mailing list for exchanging tips?</a></h2>
There is a fetchmail-friends list for people who want to discuss fixes
-and improvements in fetchmail and help co-develop it. It's at <a
-href="mailto:fetchmail-friends@thyrsus.com">fetchmail-friends@thyrsus.com</a>.
-There is also an announcements-only list, <em>fetchmail-announce@thyrsus.com</em>.<P>
+and improvements in fetchmail and help co-develop it. It's a MailMan
+list, which you can sign up for at <a
+<a href="http://lists.ccil.org/mailman/listinfo/fetchmail-friends">fetchmail-friends@lists.ccil.org</a>.
+There is also an announcements-only list, <a href="http://lists.ccil.org/mailman/listinfo/fetchmail-announce">fetchmail-announce@lists.ccil.org</em>.<P>
-Both lists are SmartList reflectors; sign up in the usual way with a
-message containing the word "subscribe" in the subject line sent to
-<a href="mailto:fetchmail-friends-request@thyrsus.com?subject=subscribe">
-fetchmail-friends-request@thyrsus.com</a> or
-<a href="mailto:fetchmail-announce-request@thyrsus.com?subject=subscribe">
-fetchmail-announce-request@thyrsus.com</a>. (Similarly, "unsubscribe"
-in the Subject line unsubscribes you, and "help" returns general list help) <p>
<hr>
<h2><a name="G6">G6. So, what's this I hear about a fetchmail paper?</a></h2>
@@ -1577,7 +1571,7 @@ project manager claims these bugs have been fixed in 6.0.<P>
<h2><a name="S8">S8. How can I use fetchmail with Hotmail?</a></h2>
You can't, yet. But <a
-href="http://www.ozemail.com.au/~peterhawkins/gotmail/">gotmail</a>
+href="http://hawkins.emu.id.au/gotmail/">gotmail</a>
might be what you need.<P>
<hr>
@@ -1644,6 +1638,10 @@ InterChange has a bug similar to the MailMax server; it reports the
message length with attachments but doesn't download them on TOP or
RETR. <p>
+On Jan 9 2001, the people at InfiniteMail sent me mail informing me that
+their new 3.61.08 release of InterChange fixes this problem. I don't
+have any reports one way or the other yet.<p>
+
<hr>
<h2><a name="K1">K1. How can I use fetchmail with SOCKS?</a></h2>
@@ -1747,7 +1745,7 @@ This configuration will enable secure mail transfer. All the
conversation between fetchmail and remote pop server will be
encrypted.<p>
-If sshd is not running on the remote mail server, you can specify
+If sshd is not running on the remote mail server, you can specify an
intermediate host running it. If you do this, however, communication
between the machine running sshd and the POP server will not be encrypted.
And the preconnect line would be like this:<p>
@@ -2980,7 +2978,7 @@ switching to IMAP and using a short expunge interval.<p>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/01/15 07:28:51 $
+<td width="30%" align=right>$Date: 2001/02/07 00:47:40 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmailconf b/fetchmailconf
index d7853c8a..e3719057 100755
--- a/fetchmailconf
+++ b/fetchmailconf
@@ -1325,12 +1325,14 @@ same messages will be downloaded over and over.
"""
if string.find(greetline, "InterChange") > 0:
warnings = warnings + """
-The InterChange IMAP server screws up on mail with attachments. It
-doesn't fetch them if you give it a BODY[TEXT] request, though it
-does if you request RFC822.TEXT. According to the IMAP RFCs and their
-maintainer these should be equivalent -- and we can't drop the
-BODY[TEXT] form because M$ Exchange (quite legally under RFC2062)
-rejects it.
+
+The InterChange IMAP server at release levels below 3.61.08 screws up
+on mail with attachments. It doesn't fetch them if you give it a
+BODY[TEXT] request, though it does if you request RFC822.TEXT.
+According to the IMAP RFCs and their maintainer these should be
+equivalent -- and we can't drop the BODY[TEXT] form because M$
+Exchange (quite legally under RFC2062) rejectsit. The InterChange
+folks claim to have fixed this bug in 3.61.08.
"""
if string.find(greetline, "Imail") > 0:
diff --git a/imap.c b/imap.c
index 39868ad5..57145194 100644
--- a/imap.c
+++ b/imap.c
@@ -898,16 +898,6 @@ int imap_getauth(int sock, struct query *ctl, char *greeting)
expunge_period = 1;
/*
- * If either (a) we saw a PREAUTH token in the greeting, or
- * (b) the user specified ssh preauthentication, then we're done.
- */
- if (preauth || ctl->server.preauthenticate == A_SSH)
- {
- preauth = FALSE; /* reset for the next session */
- return(PS_SUCCESS);
- }
-
- /*
* Handle idling. We depend on coming through here on startup
* and after each timeout (including timeouts during idles).
*/
@@ -918,6 +908,16 @@ int imap_getauth(int sock, struct query *ctl, char *greeting)
report(stdout, _("will idle after poll\n"));
}
+ /*
+ * If either (a) we saw a PREAUTH token in the greeting, or
+ * (b) the user specified ssh preauthentication, then we're done.
+ */
+ if (preauth || ctl->server.preauthenticate == A_SSH)
+ {
+ preauth = FALSE; /* reset for the next session */
+ return(PS_SUCCESS);
+ }
+
#if OPIE_ENABLE
if ((ctl->server.protocol == P_IMAP) && strstr(capabilities, "AUTH=X-OTP"))
{