aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in22
-rw-r--r--fetchmail.man15
2 files changed, 18 insertions, 19 deletions
diff --git a/Makefile.in b/Makefile.in
index 40b7449c..53620ca0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,8 +3,8 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=3.3
-PL=3
+VERS=3.4
+PL=0
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -77,19 +77,19 @@ TEXI2DVI = texi2dvi
ETAGS = etags -tw
CTAGS = ctags -tw
-protobjs = socket.o getpass.o pop2.o pop3.o imap.o etrn.o fetchmail.o options.o \
- rcfile_l.o rcfile_y.o daemon.o smtp.o driver.o rfc822.o xmalloc.o \
- uid.o mxget.o md5c.o md5ify.o interface.o netrc.o error.o
+protobjs = socket.o getpass.o pop2.o pop3.o imap.o etrn.o fetchmail.o \
+ options.o rcfile_l.o rcfile_y.o daemon.o smtp.o driver.o rfc822.o \
+ xmalloc.o uid.o mxget.o md5c.o md5ify.o interface.o netrc.o error.o
objs = $(protobjs) $(extras) $(EXTRAOBJ)
srcs = $(srcdir)/socket.c $(srcdir)/getpass.c $(srcdir)/pop2.c \
- $(srcdir)/pop3.c $(srcdir)/imap.c $(srcdir)/imap.c $(srcdir)/etrn.c \
- $(srcdir)/options.c $(srcdir)/daemon.c $(srcdir)/driver.c \
- $(srcdir)/rfc822.c $(srcdir)/smtp.c $(srcdir)/xmalloc.c \
- $(srcdir)/uid.c $(srcdir)/mxget.c $(srcdir)/md5c.c \
- $(srcdir)/md5ify.c $(srcdir)/interface.c $(srcdir)/netrc.c \
- $(srcdir)/error.c
+ $(srcdir)/pop3.c $(srcdir)/imap.c $(srcdir)/imap.c \
+ $(srcdir)/etrn.c $(srcdir)/options.c $(srcdir)/daemon.c \
+ $(srcdir)/driver.c $(srcdir)/rfc822.c $(srcdir)/smtp.c \
+ $(srcdir)/xmalloc.c $(srcdir)/uid.c $(srcdir)/mxget.c \
+ $(srcdir)/md5c.c $(srcdir)/md5ify.c $(srcdir)/interface.c \
+ $(srcdir)/netrc.c $(srcdir)/error.c
.SUFFIXES:
.SUFFIXES: .o .c .h .y .l .ps .dvi .info .texi
diff --git a/fetchmail.man b/fetchmail.man
index cfd429dc..788b3ebb 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -18,10 +18,9 @@ poll one or more systems at a specified interval.
The
.I fetchmail
program can gather mail from servers supporting any of the common
-mail-retrieval protocols: POP2 (as specified in RFC 937), POP3 (RFC
-1939), IMAP2bis (as implemented by the 4.4BSD imapd program), and
-IMAP4 (as specified by RFC 1730). It can use (but does not require)
-the LAST facility removed from later POP3 versions.
+mail-retrieval protocols: POP2, POP3, IMAP2bis, and IMAP4. It can
+also use the ESMTP ETRN extension. (The RFCs describing all these
+protocols are listed below.)
.PP
While
.I fetchmail
@@ -147,9 +146,9 @@ IMAP2bis, IMAP4, or IMAP4rev1 (\fIfetchmail\fR autodetects their capabilities).
Use the ESMTP ETRN option.
.RE
All these alternatives work in basically the same way (communicating
-with server daemons to fetch mail already delivered to a mailbox on
-the server) except ETRN. The ETRN mode allows you to ask an RFC-1985
-complient ESMTP server (such as BSD sendmail at release 8.8.0 or
+with standard server daemons to fetch mail already delivered to a
+mailbox on the server) except ETRN. The ETRN mode allows you to ask a
+compliant ESMTP server (such as BSD sendmail at release 8.8.0 or
higher) to immediately open an sender-SMTP connection to your your
client machine and begin forwarding any items addressed to your client
machine in the server's queue of undelivered mail.
@@ -1036,7 +1035,7 @@ elm(1), mail(1), sendmail(8), popd(8), imapd(8)
.SH APPLICABLE STANDARDS
.TP 5
SMTP/ESMTP:
-RFC 821, RFC 1869, RFC 1652, RFC 1870
+RFC 821, RFC 1869, RFC 1652, RFC 1870, RFC 1985
.TP 5
mail:
RFC 822