aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL4
-rw-r--r--NEWS11
-rw-r--r--driver.c2
3 files changed, 16 insertions, 1 deletions
diff --git a/INSTALL b/INSTALL
index 5ff297fe..119bff7a 100644
--- a/INSTALL
+++ b/INSTALL
@@ -5,6 +5,10 @@ If you have installed binaries (e.g. from an RPM) you can skip to step 4.
If you are a Linux system packager, be aware that the build process generates
an RPM spec file at fetchmail.spec.
+The Frequently Asked Questions list, included as the file FAQ in this
+distributions, answers the most common questions about configuring and
+running fetchmail.
+
1. CONFIGURE
Installing fetchmail is easy. From within this directory, type:
diff --git a/NEWS b/NEWS
index 28fec3c6..36131cf4 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,17 @@
Release Notes:
------------------------------------------------------------------------------
+fetchmail-3.6 ()
+
+features --
+
+* New Makefile production to generate an RPM.
+
+bugs --
+
+* Yet another fix to the password-shrouding logic.
+
+------------------------------------------------------------------------------
fetchmail-3.5 (Sat Feb 15 15:19:36 EST 1997)
Note: The .poprc compatibility hack that allows your first user declaration
diff --git a/driver.c b/driver.c
index ee2c82ba..037b46ca 100644
--- a/driver.c
+++ b/driver.c
@@ -1576,7 +1576,7 @@ va_dcl
*cp++ = '*';
while (*sp)
*cp++ = *sp++;
- *sp = '\0';
+ *cp = '\0';
}
buf[strlen(buf)-1] = '\0';
error(0, 0, "%s> %s", protocol->name, buf);