aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS3
-rw-r--r--configure.in2
-rw-r--r--odmr.c3
-rwxr-xr-xupload2
4 files changed, 8 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 311fb432..3afc9193 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,8 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* ODMR port fix for AIX.
+
fetchmail-5.6.3 (Wed Feb 7 10:56:21 EST 2001), 19901 lines:
* VPATH build fixed (thanks to Harry McGavran).
@@ -13,6 +15,7 @@ fetchmail-5.6.3 (Wed Feb 7 10:56:21 EST 2001), 19901 lines:
* ODMR (RFC 2645) support -- untested and probably buggy!
There are 276 people on fetchmail-friends and 558 on fetchmail-announce.
+% Mailing lists moved to MailMan
fetchmail-5.6.2 (Fri Jan 5 16:45:47 EST 2001), 19744 lines:
diff --git a/configure.in b/configure.in
index f692fce7..83bac3a5 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_TYPE_SIGNAL
AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h sys/itimer.h fcntl.h sys/fcntl.h memory.h sys/wait.h)
-AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h resolv.h net/socket.h)
+AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h resolv.h net/socket.h sys/select.h)
AC_C_CONST dnl getopt needs this.
diff --git a/odmr.c b/odmr.c
index 95da2469..1f3708d2 100644
--- a/odmr.c
+++ b/odmr.c
@@ -14,6 +14,9 @@
#endif
#include <sys/types.h>
#include <sys/time.h>
+#ifdef HAVE_NET_SELECT_H /* AIX needs this */
+#include <net/select.h>
+#endif
#include <netdb.h>
#include <errno.h>
#include <unistd.h>
diff --git a/upload b/upload
index 0b672d55..b576f6f2 100755
--- a/upload
+++ b/upload
@@ -7,7 +7,7 @@ if [ $* ]
then
../upload $*
else
- lftp -d <<EOF
+ lftp <<EOF
# First, copy to primary website
open ${WWWHOST}
cd ${WWWDIR}/fetchmail