diff options
-rw-r--r-- | NEWS | 5 | ||||
-rw-r--r-- | configure.in | 5 | ||||
-rw-r--r-- | fetchmail.c | 4 |
3 files changed, 12 insertions, 2 deletions
@@ -1,7 +1,12 @@ + Known bugs + +* Progress messages go to stderr. Can we send them to stdout? + Release Notes: fetchmail-4.7.5 (): * Issue proper logout after running fetchmail -c +* Fix prefix problem with internationalized version. There are 249 people on fetchmail-friends and 334 on fetchmail-announce. diff --git a/configure.in b/configure.in index b7f79903..90d96b03 100644 --- a/configure.in +++ b/configure.in @@ -202,6 +202,11 @@ if test "$USE_NLS" = "yes" then echo 'Enabling internationalization support...' POMAKE='$(MAKE) -C po' + if test "x$prefix" != xNONE; then + EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"$prefix/share/locale\"'" + else + EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"$ac_default_prefix/share/locale\"'" + fi else echo 'Disabling internationalization support...' POMAKE="@echo '(NLS support disabled)'; #" diff --git a/fetchmail.c b/fetchmail.c index 766f78e1..9edc1600 100644 --- a/fetchmail.c +++ b/fetchmail.c @@ -149,8 +149,8 @@ int main (int argc, char **argv) envquery(argc, argv); #ifdef ENABLE_NLS - bindtextdomain("fetchmail", "/usr/share/locale"); - textdomain("fetchmail"); + bindtextdomain(PACKAGE, LOCALEDIR); + textdomain(PACKAGE); #endif #define IDFILE_NAME ".fetchids" |