aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--daemon.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 6d2d3801..1a997968 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -28,7 +28,7 @@ RANLIB = @RANLIB@
# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
# See also `config.h'.
DEFS = @DEFS@
-# DEFS = -DHAVE_CONFIG_H -DQNX -DHAVE_UNISTD_H -DSTDC_HEADERS # QNX
+# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
defines = -DRELEASE_ID=\"$(VERS)\" $(DEFS)
# If your system needs extra libraries loaded in, define them here.
diff --git a/daemon.c b/daemon.c
index 771b6e8b..ea814a6c 100644
--- a/daemon.c
+++ b/daemon.c
@@ -206,7 +206,7 @@ nottyDetach:
/* set up to catch child process termination signals */
signal(SIGCLD, sigchld_handler);
-#if defined(QNX)
+#if defined(SIGPWR)
signal(SIGPWR, sigchld_handler);
#endif
}