aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS2
-rw-r--r--fetchmail.h2
-rw-r--r--rfc822.c4
3 files changed, 5 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 3a716e4e..f0105047 100644
--- a/NEWS
+++ b/NEWS
@@ -76,6 +76,8 @@ fetchmail 6.3.0 (not yet released officially):
when username contains an @ and the envelope sender is null, Debian
bug #272289 (Matthias Andree)
* configure.ac cleanups by Miloslav Trmac (Matthias Andree)
+* Miloslav Trmac's fix to reply_hack() type, for systems where
+ sizeof(int) != sizeof(size_t). (Matthias Andree)
fetchmail-6.2.5 (Wed Oct 15 18:39:22 EDT 2003), 23079 lines:
diff --git a/fetchmail.h b/fetchmail.h
index 9ce7942e..337b8607 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -542,7 +542,7 @@ void stuff_warning();
void close_warning_by_mail(struct query *, struct msgblk *);
/* rfc822.c: RFC822 header parsing */
-unsigned char *reply_hack(unsigned char *, const unsigned char *, int *);
+unsigned char *reply_hack(unsigned char *, const unsigned char *, size_t *);
unsigned char *nxtaddr(const unsigned char *);
/* uid.c: UID support */
diff --git a/rfc822.c b/rfc822.c
index 25d193b7..5e335616 100644
--- a/rfc822.c
+++ b/rfc822.c
@@ -44,7 +44,7 @@ char *program_name = "rfc822";
unsigned char *reply_hack(
unsigned char *buf /* header to be hacked */,
const unsigned char *host /* server hostname */,
- int *length)
+ size_t *length)
/* hack message headers so replies will work properly */
{
unsigned char *from, *cp, last_nws = '\0', *parens_from = NULL;
@@ -393,7 +393,7 @@ unsigned char *nxtaddr(const unsigned char *hdr /* header to be parsed, NUL to c
static void parsebuf(unsigned char *longbuf, int reply)
{
unsigned char *cp;
- int dummy;
+ size_t dummy;
if (reply)
{