aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xindexgen.sh2
-rwxr-xr-xmakerelease16
-rwxr-xr-xspecgen.sh1
3 files changed, 3 insertions, 16 deletions
diff --git a/indexgen.sh b/indexgen.sh
index d8d3b103..4d19c170 100755
--- a/indexgen.sh
+++ b/indexgen.sh
@@ -34,11 +34,9 @@ then
fi
# Cryptographically sign checksums
-su esr <<EOF
gpg --clearsign checksums
mv checksums.asc checksums
gpg --detach-sign --armor fetchmail-$version.tar.gz
-EOF
cat >index.html <<EOF
<?xml version="1.0" encoding="ISO-8859-1"?>
diff --git a/makerelease b/makerelease
index a88ade57..b1d03b5f 100755
--- a/makerelease
+++ b/makerelease
@@ -72,18 +72,14 @@ if (system("make dist $null")) {
}
print "### Building the RPMs...\n";
-if (system("make rpm $null && chown esr *.rpm")) {
+if (system("buildrpms fetchmail-${version}.tar.gz $null")) {
die("RPM-build failure\n");
}
-# Clean up permissions so next build won't foo up.
-system("chown esr config.log stamp-h po/Makefile");
-
open(REPORT, ">PREAMBLE.$$");
print REPORT <<EOF;
From: esr\@thyrsus.com (Eric S. Raymond)
-To: fetchmail-friends\@ccil.org, fetchmail-announce\@ccil.org
Reply-To: esr\@thyrsus.com (Eric S. Raymond)
Subject: The $version release of fetchmail is available
FCC: ~/postings/outmail
@@ -137,7 +133,7 @@ system("wc <DIFFS.$$");
if ($diffs) {
system "metasend -b -D 'fetchmail-$rcsid announcement' -m 'text/plain' -e 7bit -f PREAMBLE.$$ -n -D 'diff -u between -$oldrcs $rcsid' -m 'text/plain' -e 7bit -f DIFFS.$$ -o RELEASE.NOTES";
} else {
- rename("PREAMBLE.$$", "RELEASE.NOTES");
+ rename("PREAMBLE.$$", "ANNOUNCE.EMAIL");
}
system("chown esr RELEASE.NOTES");
chmod(0700, "RELEASE.NOTES");
@@ -154,14 +150,6 @@ system("rm -f testservers.html; testservers-gen.sh >testservers.html");
print "Making activity graph...";
growthplot;
-print "Making LSM...";
-$keywords="mail, client, POP, POP2, POP3, APOP, RPOP, KPOP, IMAP, ETRN, ODMR, SMTP, ESMTP, GSSAPI, RPA, NTLM, CRAM-MD5, SASL";
-system("rpm2lsm -k '$keywords' fetchmail-$version-1.i386.rpm >fetchmail.lsm");
-system("ls -l fetchmail.lsm");
-
-# Avoid leaving unwriteable files around
-system("chown -R esr .");
-
print "Done\n";
# makerelease ends here
diff --git a/specgen.sh b/specgen.sh
index 23b283ca..7531aa27 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -23,6 +23,7 @@ Summary(tr): POP2, POP3, APOP, IMAP protokolleri ile uzaktan mektup alma yazý
Summary(da): Alsidig POP/IMAP post-afhentnings dæmon
BuildRoot: %{_tmppath}/%{name}-root
#Keywords: mail, client, POP, POP2, POP3, APOP, RPOP, KPOP, IMAP, ETRN, ODMR, SMTP, ESMTP, GSSAPI, RPA, NTLM, CRAM-MD5, SASL
+#Destinations: fetchmail-friends@ccil.org, fetchmail-announce@ccil.org
%description
Fetchmail is a free, full-featured, robust, and well-documented remote