aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in38
-rw-r--r--configure.in15
-rw-r--r--driver.c2
-rw-r--r--fetchmail.c6
4 files changed, 30 insertions, 31 deletions
diff --git a/Makefile.in b/Makefile.in
index cdf5860d..a5e58e67 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,10 +3,8 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=4.6.9
-
-PACKAGE = @PACKAGE@
-VERSION = @VERSION@
+PACKAGE = fetchmail
+VERSION = 4.6.9
SUBDIRS = @INTLSUB@ @POSUB@
@@ -38,7 +36,7 @@ RANLIB = @RANLIB@
# See also `config.h'.
DEFS = @DEFS@ @EXTRADEFS@
# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
-defines = -DRELEASE_ID=\"$(VERS)\" $(DEFS)
+defines = $(DEFS)
# If your system needs extra libraries loaded in, define them here.
# In particular, add -lresolv if you are running bind 4.9.5
@@ -179,13 +177,13 @@ realclean: distclean
mostlyclean: clean
-config.status: configure
+config.status: configure Makefile.in
$(srcdir)/configure
config.h: config.status config.h.in
sh config.status; touch config.h
-Makefile: config.status Makefile.in
+Makefile: config.status
sh config.status
configure: configure.in
@@ -253,28 +251,28 @@ NOTES: design-notes.html
dist: Makefile.in
rm -f MANIFEST; make MANIFEST;
touch fetchmail.lsm
- make fetchmail-$(VERS).tar.gz
- lsmgen.sh $(VERS) `wc -c fetchmail-$(VERS).tar.gz` >fetchmail.lsm
- make fetchmail-$(VERS).tar.gz
- ls -l fetchmail-$(VERS).tar.gz
+ make fetchmail-$(VERSION).tar.gz
+ lsmgen.sh $(VERSION) `wc -c fetchmail-$(VERSION).tar.gz` >fetchmail.lsm
+ make fetchmail-$(VERSION).tar.gz
+ ls -l fetchmail-$(VERSION).tar.gz
@echo "Don't forget to build RPMs from root!"
-fetchmail-$(VERS).tar.gz: $(all)
- (cd ..; ln -sf fetchmail fetchmail-$(VERS))
- (cd ..; tar -czf fetchmail-$(VERS).tar.gz `sed <fetchmail-$(VERS)/MANIFEST s:^:fetchmail-$(VERS)/:`)
- mv -f ../fetchmail-$(VERS).tar.gz .
- rm ../fetchmail-$(VERS)
+fetchmail-$(VERSION).tar.gz: $(all)
+ (cd ..; ln -sf fetchmail fetchmail-$(VERSION))
+ (cd ..; tar -czf fetchmail-$(VERSION).tar.gz `sed <fetchmail-$(VERSION)/MANIFEST s:^:fetchmail-$(VERSION)/:`)
+ mv -f ../fetchmail-$(VERSION).tar.gz .
+ rm ../fetchmail-$(VERSION)
# Make RPMs. You need to be root to make this work
RPMROOT=/usr/src/redhat
RPM = rpm
RPMFLAGS = -ba
rpm: dist
- cp fetchmail-$(VERS).tar.gz fetchmail.gif $(RPMROOT)/SOURCES;
- $(srcdir)/specgen.sh $(VERS) >$(RPMROOT)/SPECS/fetchmail.spec
+ cp fetchmail-$(VERSION).tar.gz fetchmail.gif $(RPMROOT)/SOURCES;
+ $(srcdir)/specgen.sh $(VERSION) >$(RPMROOT)/SPECS/fetchmail.spec
cd $(RPMROOT)/SPECS; $(RPM) $(RPMFLAGS) fetchmail.spec
- cp $(RPMROOT)/RPMS/`arch|sed 's/i[4-9]86/i386/'`/fetchmail-$(VERS)*.rpm $(srcdir)
- cp $(RPMROOT)/SRPMS/fetchmail-$(VERS)*.src.rpm $(srcdir)
+ cp $(RPMROOT)/RPMS/`arch|sed 's/i[4-9]86/i386/'`/fetchmail-$(VERSION)*.rpm $(srcdir)
+ cp $(RPMROOT)/SRPMS/fetchmail-$(VERSION)*.src.rpm $(srcdir)
# The following sets edit modes for GNU EMACS.
# Local Variables:
diff --git a/configure.in b/configure.in
index 8d7427de..e29000e2 100644
--- a/configure.in
+++ b/configure.in
@@ -35,6 +35,14 @@ AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
AC_SUBST(POMAKE)
+pkg=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <Makefile.in`
+AC_DEFINE_UNQUOTED(PACKAGE, "$pkg")
+AC_SUBST(PACKAGE)
+
+vers=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <Makefile.in`
+AC_DEFINE_UNQUOTED(VERSION, "$vers")
+AC_SUBST(VERSION)
+
# Check for LynxOS special case: -lbsd needed (at least on 2.3.0) and -s
# not working.
if test `uname` = "LynxOS"
@@ -53,13 +61,6 @@ fi
# Arnaldo Carvalho de Melo <acme@conectiva.com.br>
# Sat Nov 7 15:39:03 EDT 1998
-PACKAGE=fetchmail
-VERSION=4.6.7
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-
ALL_LINGUAS="pt_BR"
AM_GNU_GETTEXT
diff --git a/driver.c b/driver.c
index a313de19..72065614 100644
--- a/driver.c
+++ b/driver.c
@@ -919,7 +919,7 @@ static int readheaders(int sock, long fetchlen, long reallen, struct query *ctl,
sprintf(buf, "\tby %s with %s (fetchmail-%s)\r\n",
fetchmailhost,
protocol->name,
- RELEASE_ID);
+ VERSION);
n = stuffline(ctl, buf);
if (n != -1)
{
diff --git a/fetchmail.c b/fetchmail.c
index cafde674..7d368e1b 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -171,7 +171,7 @@ int main (int argc, char **argv)
if (versioninfo)
{
- printf(_("This is fetchmail release %s"), RELEASE_ID);
+ printf(_("This is fetchmail release %s"), VERSION);
#ifdef POP2_ENABLE
printf("+POP2");
#endif /* POP2_ENABLE */
@@ -456,7 +456,7 @@ int main (int argc, char **argv)
{
if (!nodetach)
daemonize(run.logfile, termhook);
- error( 0, 0, _("starting fetchmail %s daemon "), RELEASE_ID);
+ error( 0, 0, _("starting fetchmail %s daemon "), VERSION);
/*
* We'll set up a handler for these when we're sleeping,
@@ -1214,7 +1214,7 @@ static int query_host(struct query *ctl)
time(&now);
error(0, -1, _("fetchmail: %s querying %s (protocol %s) at %s"),
- RELEASE_ID,
+ VERSION,
ctl->server.pollname, showproto(ctl->server.protocol), ctime(&now));
}
switch (ctl->server.protocol) {