aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in12
-rw-r--r--NEWS9
-rw-r--r--report.c50
3 files changed, 27 insertions, 44 deletions
diff --git a/Makefile.in b/Makefile.in
index de7b3016..7ef19194 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,7 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=3.9.1
+VERS=3.9.2
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -112,23 +112,23 @@ rfc822: rfc822.c
# lex rule
.l.o:
$(LEX) $(LEXFLAGS) $<
- mv lex.yy.c $*
+ mv lex.yy.c $*.c
$(CC) $(defines) -c -I. -I$(srcdir) $(CFLAGS) $*.c $(OUTPUT_OPTION)
.l.c:
$(LEX) $(LEXFLAGS) $<
- mv lex.yy.c $@
+ mv lex.yy.c $*.c
# yacc rule
.y.o:
$(YACC) $(YACCFLAGS) $<
- mv y.tab.c $@
+ mv y.tab.c $*.c
mv -f y.tab.h $*.h
$(CC) $(defines) -c -I. -I$(srcdir) $(CFLAGS) $*.c $(OUTPUT_OPTION)
.y.c:
$(YACC) $(YACCFLAGS) $<
- mv y.tab.c $@
+ mv y.tab.c $*.c
mv -f y.tab.h $*.h
# For some losing Unix makes.
@@ -211,7 +211,7 @@ scripts = $(srcdir)/install.sh $(srcdir)/mkinstalldirs $(srcdir)/specgen.sh
all = $(docs) $(config) $(srcs) $(parser) $(headers) $(extra) $(scripts) \
$(srcdir)/contrib/* $(srcdir)/MANIFEST
-MANIFEST: $(srcdir)
+MANIFEST: $(srcdir) Makefile.in
@echo $(all) | tr "[ \t]" '\n' | sort | sed "s/\\./fetchmail-$(VERS)/" >MANIFEST
FAQ: fetchmail.FAQ.html
diff --git a/NEWS b/NEWS
index cd96f539..83e5e4e4 100644
--- a/NEWS
+++ b/NEWS
@@ -9,6 +9,10 @@ every user entry in a multi-user poll declaration.
Known But Unresolved Bugs:
+In multidrop mode without an applicable localdomain, addresses of the
+form "foo"@bar.com are not parsed correctly, even though they are
+technically RFC822 legal.
+
Rich Kulawiec <rsk@itw.com> writes:
Problem: fetchmail 3.9 seems to work fine when run from a tty or pty,
@@ -24,6 +28,11 @@ having trouble figuring why it wouldn't just break *all* the time.)
------------------------------------------------------------------------------
+pl 3.9.2 ():
+* Fixed a glitch in the Makefile yacc and lex productions
+* Add logic for X-Fetchmail-Warning emission of \r\n to pacify qmail.
+* Yet another try at getting error.c to play nice with AIX.
+
pl 3.9.1 (Thu Apr 17 11:37:14 EDT 1997):
* Hypertext FAQ added to distribution manifest.
* RPM builder production fixed.
diff --git a/report.c b/report.c
index 239beaf1..e1e0b745 100644
--- a/report.c
+++ b/report.c
@@ -117,34 +117,6 @@ private_strerror (errnum)
Exit with status STATUS if it is nonzero. */
/* VARARGS */
-#if !defined(HAVE_VSYSLOG)
-#if defined(VA_START) && __STDC__
-int vsyslog(int priority, char *message, ...)
-#else
-int vsyslog(priority, message, va_alist)
-int priority;
-char *message;
-va_dcl
-#endif
-{
-#ifdef VA_START
- va_list args;
-#endif
-
- char *string;
-
- string = (char *)malloc(LINELEN);
-
- VA_START (ap, fmt) ;
-
- vsprintf(string, message, args);
- va_end(args);
-
- syslog(priority, string);
- free(string);
-}
-#endif
-
void
#if defined(VA_START) && __STDC__
error (int status, int errnum, const char *message, ...)
@@ -172,9 +144,9 @@ error (status, errnum, message, va_alist)
{
int priority;
-# ifdef VA_START
+#ifdef VA_START
VA_START (args, message);
-# endif
+#endif
priority = status? LOG_ALERT : errnum? LOG_ERR : LOG_INFO;
if (errnum > 0)
@@ -185,22 +157,24 @@ error (status, errnum, message, va_alist)
strcat (msg, ": %m");
errno = errnum;
-# ifdef VA_START
+#ifdef HAVE_VSYSLOG
vsyslog (priority, msg, args);
- va_end (args);
-# else
+#else
syslog (priority, msg, a1, a2, a3, a4, a5, a6, a7, a8);
-# endif
+#endif
}
else
{
-# ifdef VA_START
+#ifdef HAVE_VSYSLOG
vsyslog (priority, message, args);
- va_end (args);
-# else
+#else
syslog (priority, message, a1, a2, a3, a4, a5, a6, a7, a8);
-# endif
+#endif
}
+
+#ifdef VA_START
+ va_end(args);
+#endif
}
else
#endif