aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS4
-rw-r--r--configure.in4
-rw-r--r--driver.c4
-rw-r--r--fetchmail-FAQ.html11
-rw-r--r--fetchmail.c2
-rw-r--r--fetchmail.man6
-rw-r--r--interface.c2
-rw-r--r--sink.c3
8 files changed, 23 insertions, 13 deletions
diff --git a/NEWS b/NEWS
index 68bb34da..f2a1c1f9 100644
--- a/NEWS
+++ b/NEWS
@@ -2,9 +2,11 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* Interface option fix from Alexander Kourakov.
+* Fixes for i18n glitches and new Danish translation from Byrial Jensen.
* Attempted fix for Harry McGavran's problems with the Kerberos V build.
* Added fetchmailnochda.pl to the contrib directory.
-* Sunil Shetye's patch for the seen count on IMAP.
+* Sunil Shetye's patches for the seen count on IMAP and auto protocol.
fetchmail-5.8.4 (Mon May 21 15:08:03 EDT 2001), 20636 lines:
diff --git a/configure.in b/configure.in
index 566a4ea4..20e458d1 100644
--- a/configure.in
+++ b/configure.in
@@ -221,7 +221,7 @@ AC_DEFINE_UNQUOTED(PID_DIR, "$dir")
# a sendmail alias) do the right thing in this circumstance.
#
AC_PATH_PROG(procmail, procmail, "", $PATH:/usr/sbin)
-AC_PATH_PROG(sendmail, sendmail, "", $PATH:/usr/sbin)
+AC_PATH_PROG(sendmail, sendmail, "", $PATH:/usr/sbin:/usr/lib)
### use option --disable-fallback to disable fallback MDA
### use option --enable-fallback=procmail or
@@ -456,7 +456,7 @@ directory],
if test "$with_kerberos" != "no"
then
# Check for a NetBSD/OpenBSD special case
-if test "$with_kerberos" = "yes" && ( test `uname` = "NetBSD" || test `uname`= "OpenBSD" )
+if test "$with_kerberos" = "yes" && ( test `uname` = "NetBSD" || test `uname` = "OpenBSD" )
then
AC_CHECKING([kerberosIV for `uname`])
AC_DEFINE(KERBEROS_V4)
diff --git a/driver.c b/driver.c
index 6e12a672..505bf26c 100644
--- a/driver.c
+++ b/driver.c
@@ -1823,7 +1823,7 @@ const int maxfetch; /* maximum number of messages to fetch */
report(stderr, _("Authorization failure on %s@%s%s\n"),
ctl->remotename,
ctl->server.truename,
- (ctl->wehaveauthed ? " (previously authorized)" : " ")
+ (ctl->wehaveauthed ? _(" (previously authorized)") : "")
);
/*
@@ -2552,6 +2552,8 @@ const struct method *proto; /* protocol method table */
int fetchlimit = NUM_VALUE_OUT(ctl->fetchlimit);
do {
+ if (fetchlimit > 0 && (expunge == 0 || expunge > fetchlimit - totalcount))
+ expunge = fetchlimit - totalcount;
ok = do_session(ctl, proto, expunge);
totalcount += expunge;
if (NUM_SPECIFIED(ctl->fetchlimit) && totalcount >= fetchlimit)
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index 439f521f..152b7682 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/05/21 17:13:04 $
+<td width="30%" align=right>$Date: 2001/05/29 22:48:04 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -156,6 +156,7 @@ a line hit while downloading?</a><br>
<a href="#O8">O8. I'm using pppd. Why isn't my monitor option working?</a><br>
<a href="#O9">O9. Why does fetchmail keep retrieving the same messages
over and over?</a><br>
+<a href="#O10">O10. Why is the received date on all my messages the same?</a><br>
<h1>Answers:</h1>
<hr>
@@ -2848,11 +2849,17 @@ terminated correctly.
to behave on a line drop, according to the RFCs. I recommend
switching to IMAP and using a short expunge interval.
+<hr>
+<h2><a name="O10">O10. Why is the received date on all my messages the same?</a></h2>
+
+This is a design choice in your MTA, not fetchmail. It's taking the received
+date from the last Received header.<p>
+
<HR>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/05/21 17:13:04 $
+<td width="30%" align=right>$Date: 2001/05/29 22:48:04 $
</table>
<ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmail.c b/fetchmail.c
index a2343614..c2a2880e 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -1376,7 +1376,7 @@ static int query_host(struct query *ctl)
for (i = 0; i < sizeof(autoprobe)/sizeof(autoprobe[0]); i++)
{
ctl->server.protocol = autoprobe[i];
- if ((st = query_host(ctl)) == PS_SUCCESS || st == PS_NOMAIL || st == PS_AUTHFAIL || st == PS_LOCKBUSY || st == PS_SMTP)
+ if ((st = query_host(ctl)) == PS_SUCCESS || st == PS_NOMAIL || st == PS_AUTHFAIL || st == PS_LOCKBUSY || st == PS_SMTP || st == PS_MAXFETCH)
break;
}
ctl->server.protocol = P_AUTO;
diff --git a/fetchmail.man b/fetchmail.man
index ee92063c..9c1588f9 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -2131,10 +2131,8 @@ The RFC 2177 IDLE support is flaky. It sort of works, but may generate
spurious socket error messages or silently hang in the presence of
various network or server errors.
.PP
-The combination of using a remote name with embedded spaces and POP3
-UIDs will not work; the UIDL-handling code will core-dump while trying
-to read in what it sees as malformed .fetchids lines, typically
-on the second poll after startup.
+The -f - option (reading a configuration from stdin) is incompatible
+with the plugin option.
.PP
The UIDL code is generally flaky and tends to lose its state on errors
and line drops (so that old messages are re-seen). If this happens to
diff --git a/interface.c b/interface.c
index 0df520f9..1d61b367 100644
--- a/interface.c
+++ b/interface.c
@@ -181,7 +181,7 @@ static int get_ifinfo(const char *ifname, ifinfo_t *ifinfo)
*sp = '/';
}
if (socket_fd >= 0)
- SockClose(close(socket_fd));
+ SockClose(socket_fd);
if (stats_file)
fclose(stats_file); /* not checking should be safe, mode was "r" */
return(result);
diff --git a/sink.c b/sink.c
index 0f1d4f3a..32ee7f11 100644
--- a/sink.c
+++ b/sink.c
@@ -767,7 +767,8 @@ int open_sink(struct query *ctl, struct msgblk *msg,
*/
ctl->mda = FALLBACK_MDA;
- report(stderr, _("can't raise the listener; falling back to " FALLBACK_MDA));
+ report(stderr, _("can't raise the listener; falling back to %s",
+ FALLBACK_MDA));
#endif
}