aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS1
-rw-r--r--configure.ac11
2 files changed, 6 insertions, 6 deletions
diff --git a/NEWS b/NEWS
index 8e5bc68d..3fcefab4 100644
--- a/NEWS
+++ b/NEWS
@@ -104,6 +104,7 @@ fetchmail-6.4.25 (not yet released):
# BUG FIXES
* 6.4.24's workaround for OpenSSL 1.0.2's X509_V_FLAG_TRUSTED_FIRST flag
contained a typo and would not kick in properly.
+* Library and/or rpath setting from configure.ac was fixed.
--------------------------------------------------------------------------------
fetchmail-6.4.24 (released 2021-11-20, 30218 LoC):
diff --git a/configure.ac b/configure.ac
index ba21272d..140489e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,8 @@ AM_PROG_AR
AC_PROG_RANLIB
AM_PROG_CC_C_O
+AC_LIB_RPATH
+
AC_ISC_POSIX
dnl AC_ISC_POSIX: - XXX FIXME: remove in fetchmail 6.4.
dnl This macro adds `-lcposix' to output variable `LIBS' if necessary
@@ -612,7 +614,7 @@ else
AC_DEFINE(KERBEROS_V5)
test "$dir" != "/usr" && CFLAGS="$CFLAGS -I$dir/include"
LDFLAGS="$LDFLAGS -L$dir/lib"
- LIBS="$LIBS $ac_krblibs $libk5crypto"
+ LIBS="$LIBS $ac_krblibs $libk5crypto"
with_kerberos5=$dir
break
else
@@ -777,9 +779,8 @@ then
PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
LDFLAGS="$LDFLAGS -L$with_ssl/lib"
- AC_LIB_LINKFLAGS([crypto])
AC_LIB_LINKFLAGS([ssl], [crypto])
- LIBS="$LIBS $LIBSSL $LIBCRYPTO"
+ LIBS="$LIBSSL $LIBS"
dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
found=0
@@ -805,10 +806,8 @@ fi
if test "$cross_compiling" != yes -a "$with_ssl" != "no"
then
- AC_LIB_LINKFLAGS([crypto])
AC_LIB_LINKFLAGS([ssl], [crypto])
-
- LIBS="$LIBS $LIBSSL $LIBCRYPTO"
+ LIBS="$LIBSSL $LIBS"
fi
AC_MSG_NOTICE([LIBS:] "$LIBS")