aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS2
-rw-r--r--configure.ac14
2 files changed, 12 insertions, 4 deletions
diff --git a/NEWS b/NEWS
index fa119da2..7c52c263 100644
--- a/NEWS
+++ b/NEWS
@@ -215,6 +215,8 @@ fetchmail 6.3.0 (not yet released officially):
* Add -DBIND_8_COMPAT to Darwin (MacOS X) compiles, to fix build problems on
newer Darwin versions. Matthias Andree.
* fetchmail should now automatically detect if OpenSSL requires -ldl.
+ Matthias Andree.
+* Fix Solaris build with --disable-nls (blastwave.org). Matthias Andree.
# INTERNAL CHANGES
* Switched to automake. Matthias Andree.
diff --git a/configure.ac b/configure.ac
index 58e0bc53..5ade7178 100644
--- a/configure.ac
+++ b/configure.ac
@@ -600,13 +600,19 @@ then
fi
LDEFLAGS="$LDEFLAGS -L$with_ssl/lib"
LIBS="$LIBS -lssl -lcrypto"
- dnl check if -ldl is needed!
+ dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
+ found=0
+ save_LIBS="$LIBS"
for i in "" "-ldl" ; do
- save_LIBS="$LIBS"
- LIBS="$LIBS $i"
- AC_LINK_IFELSE([AC_LANG_PROGRAM(,[SSL_library_init()])],break,LIBS="$save_LIBS")
+ LIBS="$LDEFLAGS $save_LIBS $i"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(,[SSL_library_init()])],[found=1; break])
done
+ if test $found = 0 ; then
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([cannot link with SSL - check config.log])
+ fi
+ LIBS="$save_LIBS $i"
if test "$i" = "" ; then i="(none)" ; fi
AC_MSG_RESULT($i)
dnl XXX FIXME: use pkg-config if available!