aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS10
-rw-r--r--fetchmail-FAQ.html26
-rw-r--r--fetchmail.h12
-rw-r--r--fetchmail.man16
5 files changed, 55 insertions, 11 deletions
diff --git a/Makefile.in b/Makefile.in
index deb45e02..269976f8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.5.4
+VERSION = 5.5.5
SUBDIRS = @INTLSUB@ @POSUB@
diff --git a/NEWS b/NEWS
index 0cb75f1f..74d3ea55 100644
--- a/NEWS
+++ b/NEWS
@@ -2,7 +2,15 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
-fetchmail-5.5.3 (Sun Oct 8 10:57:37 EDT 2000), 19518 lines:
+fetchmail-5.5.5 (Tue Oct 17 17:50:46 EDT 2000), 19523 lines:
+
+* Killed a nasty segfault due to double-freeing of the header block.
+* Updated Danish internationalization by Byrial Jensen.
+* Added FAQ item X7 on attachment hangs.
+
+There are 277 people on fetchmail-friends and 558 on fetchmail-announce.
+
+fetchmail-5.5.4 (Sun Oct 8 10:57:37 EDT 2000), 19518 lines:
* Fall back on the computed queryname if we need the DNS name of a a host
and can't get it. Resolves Debian bug #69199.
* Andrej Borsenkow's fix for configuration with new SOCKS.
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index d4fe8bc0..18599d6d 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/10/08 14:34:19 $
+<td width="30%" align=right>$Date: 2000/10/17 21:52:38 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -138,6 +138,7 @@ my Received headers as it should.</a><br>
<a href="#X4">X4. My mail is being mangled in a new and different way.</a><br>
<a href="#X5">X5. Using POP3, retrievals seems to be fetching too much!</a><br>
<a href="#X6">X6. My mail attachments are being dropped or mangled.</a><br>
+<a href="#X7">X7. Some mail attachments are hanging fetchmail.</a><br>
<h1>Other problems:</h1>
@@ -2713,6 +2714,27 @@ understand its attachments, so it really shouldn't be used at all),
and make sure dtmail is set to use MIME rather than mailtool's format.<p>
<hr>
+<h2><a name="X7">X7. Some mail attachments are hanging fetchmail.</a></h2>
+
+This isn't fetchmail's problem either; fetchmail doesn't know anything
+about mail attachments and doesn't treat them any differently from
+plain message data.<P>
+
+The most usual cause of this problem seems to be bugs in your network
+transport layer's capability to handle the very large TCP/IP packets
+that attachments tend to turn into. You can test this theory by trying to
+download the offending message through a webmail account; using HTTP
+for the message tends to simulate large-packet stress rather well, and
+you will probably find that the messages that seem to be choking
+fetchmail will make your HTTP download speed drop to zero.<P>
+
+This problem can be caused by subtle bugs in the packet-reassembly
+layer of your TCP/IP stack; these often don't manifest at normal
+packet sizes. It may also be caused by malfunctioning path-MTU
+discovery on the mailserver. Or, if there's a modem in the link,
+it may be because the attachment contains the Hayes mode escape "+++".
+
+<hr>
<h2><a name="O1">O1. The --logfile option doesn't work if the logfile doesn't exist.</a></h2>
This is a feature, not a bug. It's in line with normal practice for
@@ -2919,7 +2941,7 @@ install Linux on your server...<p>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/10/08 14:34:19 $
+<td width="30%" align=right>$Date: 2000/10/17 21:52:38 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmail.h b/fetchmail.h
index bba30e21..c0ffce33 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -560,4 +560,16 @@ char *strerror ();
#endif
#endif
+#ifdef FETCHMAIL_DEBUG
+#define exit(e) do { \
+ FILE *out; \
+ out = fopen("/tmp/fetchmail.log", "a"); \
+ fprintf(out, \
+ "Exiting fetchmail from file %s, line %d with status %d\n", \
+ __FILE__, __LINE__, e); \
+ fclose(out); \
+ _exit(e); \
+ } while(0)
+#endif /* FETCHMAIL_DEBUG */
+
/* fetchmail.h ends here */
diff --git a/fetchmail.man b/fetchmail.man
index d45aff5f..664f13f3 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -236,13 +236,15 @@ succession, fetchmail will consider it wedged and stop retrying,
the calkling user will be notified by email if this happens.
.TP
.B \--plugin <command>
-(Keyword: plugin)
-The plugin option allows you to use an external program to establish the
-TCP connection. This is useful if you want to use socks, SSL, ssh, or
-need some special firewalling setup. The program will be looked up in
-$PATH and can optionally be passed the hostname and port as arguments
-using "%h" and "%p" respectively. Fetchmail will write to the plugin's
-stdin and read from the plugin's stdout.
+(Keyword: plugin) The plugin option allows you to use an external
+program to establish the TCP connection. This is useful if you want
+to use socks, SSL, ssh, or need some special firewalling setup. The
+program will be looked up in $PATH and can optionally be passed the
+hostname and port as arguments using "%h" and "%p" respectively (note
+that the interpolation logic is rather promitive, and these token must
+be bounded by whitespace or beginning of string or end of stribg).
+Fetchmail will write to the plugin's stdin and read from the plugin's
+stdout.
.TP
.B \--plugout <command>
(Keyword: plugout)