aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS2
-rw-r--r--configure.in3
-rw-r--r--driver.c2
-rw-r--r--uid.c3
4 files changed, 8 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 19ff3b3b..4fc2d4e2 100644
--- a/NEWS
+++ b/NEWS
@@ -7,6 +7,8 @@
* Fixed a bug in fetchmailconf's handling of envelope skip prefixes.
* Don't nuke .fetchids when authorization failure keeps us from getting URLs.
* Added FAQ item X6 on dropped and mangled attachments, thanks to Rob Funk.
+* Teach configure.in to link the RSA reference library if available.
+* Disable saving of Message-IDs into UIDL lists.
There are 291 people on fetchmail-friends and 500 on fetchmail-announce.
diff --git a/configure.in b/configure.in
index 6abadb60..b753344a 100644
--- a/configure.in
+++ b/configure.in
@@ -154,6 +154,9 @@ AC_CHECK_FUNC(res_search,
dnl Check for libcrypt
AC_CHECK_LIB(crypt,crypt)
+dnl Check for RSA refersence library in case we're using SSL
+AC_CHECK_LIB(rsaref, _RSAPublicDecrypt)
+
dnl AC_FUNC_SETVBUF_REVERSED
dnl Check for usable void pointer type
diff --git a/driver.c b/driver.c
index b10a1dd4..2dfbd910 100644
--- a/driver.c
+++ b/driver.c
@@ -725,6 +725,7 @@ static int readheaders(int sock,
else if (!strncasecmp("Resent-Sender:", line, 14))
resent_sender_offs = (line - msgblk.headers);
+#ifdef __UNUSED__
else if (!strncasecmp("Message-Id:", buf, 11))
{
if (ctl->server.uidl)
@@ -740,6 +741,7 @@ static int readheaders(int sock,
}
}
}
+#endif /* __UNUSED__ */
else if (!MULTIDROP(ctl))
continue;
diff --git a/uid.c b/uid.c
index 2f388a23..ce875956 100644
--- a/uid.c
+++ b/uid.c
@@ -429,7 +429,7 @@ void uid_end_query(struct query *ctl)
* This is necessary in order to keep UIDL information
* from being heedlessly deleted later on.
*/
- if (ctl->have_uids)
+ if (ctl->newsaved)
{
/* old state of mailbox may now be irrelevant */
if (outlevel >= O_DEBUG)
@@ -438,7 +438,6 @@ void uid_end_query(struct query *ctl)
free_str_list(&scratchlist);
ctl->oldsaved = ctl->newsaved;
ctl->newsaved = (struct idlist *) NULL;
- ctl->have_uids = FALSE;
}
else if (outlevel >= O_DEBUG)
report(stdout, "not swapping UID lists, no UIDs seen this query\n");