aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in49
-rw-r--r--NEWS7
-rw-r--r--configure.in5
3 files changed, 28 insertions, 33 deletions
diff --git a/Makefile.in b/Makefile.in
index 691755ed..f712dc65 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -108,7 +108,7 @@ rfc822: rfc822.c
gcc -DTESTMAIN -g rfc822.c -o rfc822
.c.o:
- $(CC) $(defines) -c -I$(srcdir) $(CFLAGS) $< $(OUTPUT_OPTION)
+ $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $< $(OUTPUT_OPTION)
# For some losing Unix makes.
SHELL = /bin/sh
@@ -153,37 +153,37 @@ realclean: distclean # fetchmail.info*
mostlyclean: clean
-Makefile: config.status $(srcdir)/Makefile.in
- $(SHELL) config.status
- @echo "You can ignore any makedepend error messages"
- -makedepend -I$(srcdir) -I. -fMakefile *.c
+config.status: configure
+ $(srcdir)/configure
-config.h: stamp-config
+config.h: config.status config.h.in
+ sh config.status
-stamp-config: config.status $(srcdir)/config.h.in
- $(SHELL) config.status
- touch stamp-config
+Makefile: config.status Makefile.in
+ sh config.status
configure: configure.in
autoconf $(ACFLAGS)
config.h.in: acconfig.h configure.in
- autoheader $(ACFLAGS); touch config.h.in
+ autoheader $(ACFLAGS)
# This tells versions [3.59,3.63) of GNU make not to export all variables.
.NOEXPORT:
-# Special dependencies, not easily handled without explicit rules
-rcfile_l.o rcfile_l.h: $(srcdir)/rcfile_l.l
- $(LEX) $(LEXFLAGS) $<
- mv lex.yy.c $*.c
- $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $*.c $(OUTPUT_OPTION)
+# Special dependencies, not easily handled portably without explicit rules
+rcfile_l.c rcfile_l.h: $(srcdir)/rcfile_l.l
+ $(LEX) $(LEXFLAGS) $(srcdir)/rcfile_l.l
+ mv lex.yy.c rcfile_l.c
+rcfile_y.c rcfile_y.h: $(srcdir)/rcfile_y.y
+ $(YACC) $(YACCFLAGS) $(srcdir)/rcfile_y.y
+ mv y.tab.c rcfile_y.c
+ mv -f y.tab.h rcfile_y.h
-rcfile_y.o rcfile_y.h: $(srcdir)/rcfile_y.y
- $(YACC) $(YACCFLAGS) $<
- mv y.tab.c $*.c
- mv -f y.tab.h $*.h
- $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $*.c $(OUTPUT_OPTION)
+# These must be explicit, because the .c files often don't exist at
+# makefile build time.
+rcfile_l.o: rcfile_y.c rcfile_y.h config.h fetchmail.h
+rcfile_y.o: rcfile_y.c rcfile_y.h config.h fetchmail.h
parser = $(srcdir)/rcfile_l.l $(srcdir)/rcfile_y.y
headers = $(srcdir)/fetchmail.h $(srcdir)/socket.h $(srcdir)/smtp.h \
@@ -246,12 +246,5 @@ rpm: dist
cp $(RPMROOT)/RPMS/`arch|sed 's/i[4-9]86/i386/'`/fetchmail-$(VERS)*.rpm $(srcdir)
cp $(RPMROOT)/SRPMS/fetchmail-$(VERS)*.src.rpm $(srcdir)
-# The automatically generated dependencies below may omit config.h
-# because it is included with ``#include <config.h>'' rather than
-# ``#include "config.h"''. So we add the explicit dependency to make sure.
-$(objs): config.h
-
-rcfile_l.o: rcfile_y.h
-
# Automatically generated dependencies will be put at the end of the makefile.
-# DO NOT DELETE THIS LINE -- make depend depends on it.
+# DO NOT DELETE THIS LINE -- makedepend depends on it.
diff --git a/NEWS b/NEWS
index 5d7f3174..607a2ce2 100644
--- a/NEWS
+++ b/NEWS
@@ -19,7 +19,10 @@
Release Notes:
------------------------------------------------------------------------------
-fetchmail 4.0.3 (Mon Jul 28 16:39:17 EDT 1997)
+fetchmail-4.0.4 ()
+* Overhauled the build machinery.
+
+fetchmail-4.0.3 (Mon Jul 28 16:39:17 EDT 1997)
* Replace vsprintf with vnsprintf to avoid buffer-overrun screws.
* Added via option to make ssh configuration cleaner.
* Added dropstatus option.
@@ -30,7 +33,7 @@ Note: RFC1938 support is tentative, untested, and requires a patch to the
LIBOPIE library. See the file LIBOPIE.PATCH for the sad details.
There are 258 people on the fetchmail-friends list.
-fetchmail 4.0.2 (Mon Jul 17 20:54:30 EDT 1997)
+fetchmail-4.0.2 (Mon Jul 17 20:54:30 EDT 1997)
* Experimental RFC1938 one-time password support using OPIE library,
courtesy of Craig Metz <cmetz@inner.net> (couthor of RFC1938).
diff --git a/configure.in b/configure.in
index 241140d7..a1b1699b 100644
--- a/configure.in
+++ b/configure.in
@@ -150,9 +150,8 @@ else
fi
AC_OUTPUT(Makefile, [
-# Makefile uses this timestamp file to know when to remake Makefile,
-# build.sh, and glob/Makefile.
-touch stamp-config])
+ echo "You can ignore any makedepend error messages";
+ makedepend -I$srcdir -I. -fMakefile *.c])
dnl Local Variables:
dnl comment-start: "dnl "