aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in16
-rwxr-xr-xspecgen.sh1
2 files changed, 10 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index ab286531..b01f8feb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -53,8 +53,6 @@ prefix = @prefix@
# Common prefix for machine-dependent installed files.
exec_prefix = @exec_prefix@
-# Name under which to install fetchmail
-instname = fetchmail
# Directory in which to install.
bindir = @bindir@
# Directory to install the Info files in.
@@ -130,21 +128,25 @@ tags: $(tagsrcs)
$(CTAGS) $(tagsrcs)
.PHONY: install installdirs uninstall
-install: installdirs $(bindir)/$(instname) $(mandir)/$(instname).$(manext)
+install: installdirs $(bindir)/fetchmail $(bindir)/fetchmailconf $(mandir)/fetchmail.$(manext)
installdirs:
$(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(mandir)
-$(bindir)/$(instname): fetchmail
- @echo "Installing binary..."
+$(bindir)/fetchmail: fetchmail
+ @echo "Installing fetchmail binary..."
$(INSTALL_PROGRAM) fetchmail $@
-$(mandir)/$(instname).$(manext): fetchmail.man
+$(bindir)/fetchmailconf: fetchmailconf
+ @echo "Installing fetchmail configurator..."
+ $(INSTALL_PROGRAM) fetchmailconf $@
+
+$(mandir)/fetchmail.$(manext): fetchmail.man
@echo "Installing manual page..."
$(INSTALL_DATA) $(srcdir)/fetchmail.man $@
uninstall:
- rm -f $(bindir)/$(instname) $(mandir)/$(instname).$(manext)
+ rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf $(mandir)/fetchmail.$(manext)
.PHONY: clean realclean distclean mostlyclean
clean:
diff --git a/specgen.sh b/specgen.sh
index ef77d8c3..82a929e9 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -35,5 +35,6 @@ rm -rf $RPM_BUILD_ROOT
%files
%doc README NEWS NOTES fetchmail-FAQ.html FAQ COPYING INSTALL sample.rcfile
/usr/bin/fetchmail
+/usr/bin/fetchmailconf
/usr/man/man1/fetchmail.1
EOF