aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e29000e2..217f1ba2 100644
--- a/configure.in
+++ b/configure.in
@@ -76,6 +76,11 @@ AC_CHECK_FUNC(socket,
AC_CHECK_LIB(socket,socket)
AC_CHECK_LIB(inet,socket))
+# If gettext isn't in the C library, maybe there's a -lintl.
+AC_CHECK_FUNC(gettext,
+ AC_MSG_RESULT(using libc's gettext),
+ AC_CHECK_LIB(intl,gettext))
+
# The condition in this test copes with the presence of inet_addr in libc6.
AC_CHECK_FUNC(inet_addr,
AC_MSG_RESULT(using libc's inet_addr),