aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS4
-rw-r--r--configure.in4
-rw-r--r--driver.c2
-rw-r--r--fetchmail.h2
-rw-r--r--socket.c2
-rw-r--r--socket.h2
7 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index 941c4cd0..ed563464 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,7 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=4.3.1
+VERS=4.3.2
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 1bcec69b..55cef55b 100644
--- a/NEWS
+++ b/NEWS
@@ -11,14 +11,14 @@
Release Notes:
------------------------------------------------------------------------------
-fetchmail-4.3.2 ()
+fetchmail-4.3.2 (Wed Oct 22 20:30:14 EDT 1997)
* More slow-UIDL patches from Wolfgang Wander.
* Yet another attempt to fix IMAP-K4. This one, my beta-testers say, works.
* Only re-poll on actual dispatches (not just fetches).
* kwrohrer's patch for interface option on newer Linux kernels.
* Handle repolling multiple folders correctly.
-There are 262 people on fetchmail-friends and 54 on fetchmail-announce.
+There are 261 people on fetchmail-friends and 64 on fetchmail-announce.
fetchmail-4.3.1 (Mon Oct 13 17:12:40 EDT 1997)
* Minor portation fixes for early AIX versions and NextSTEP.
diff --git a/configure.in b/configure.in
index 32f756b3..a8275080 100644
--- a/configure.in
+++ b/configure.in
@@ -79,8 +79,8 @@ AC_SUBST(EXTRASRC)
AC_SUBST(EXTRAOBJ)
AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search herror \
- strrchr strerror setlinebuf syslog snprintf vsnprintf vsyslog atexit \
- inet_aton)
+ strrchr strerror setlinebuf syslog snprintf vprintf vsnprintf vsyslog \
+ atexit inet_aton)
# Under Red Hat 4.0 (and many other Linuxes) -lresolv is seriously flaky
# and breaks gethostbyname(2). It's better to use the bind stuff in the C
diff --git a/driver.c b/driver.c
index dbc97ab6..482adbb1 100644
--- a/driver.c
+++ b/driver.c
@@ -1993,7 +1993,7 @@ closeUp:
}
#if defined(HAVE_STDARG_H)
-void gen_send(int sock, char *fmt, ... )
+void gen_send(int sock, const char *fmt, ... )
/* assemble command in printf(3) style and send to the server */
#else
void gen_send(sock, fmt, va_alist)
diff --git a/fetchmail.h b/fetchmail.h
index 933a7cbe..c8989a04 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -247,7 +247,7 @@ void error_at_line ();
/* driver.c: transaction support */
#if defined(HAVE_STDARG_H)
-void gen_send (int sock, char *, ... );
+void gen_send (int sock, const char *, ... );
int gen_recv(int sock, char *buf, int size);
int gen_transact (int sock, char *, ... );
#else
diff --git a/socket.c b/socket.c
index d881498c..58ca8cfd 100644
--- a/socket.c
+++ b/socket.c
@@ -38,7 +38,7 @@
#endif
#endif /* INET_ATON */
-int SockOpen(char *host, int clientPort)
+int SockOpen(const char *host, int clientPort)
{
int sock;
#ifndef INET_ATON
diff --git a/socket.h b/socket.h
index 20ef73a6..42f5c512 100644
--- a/socket.h
+++ b/socket.h
@@ -8,7 +8,7 @@
#define SOCKET__
/* Create a new client socket; returns (FILE *)NULL on error */
-int SockOpen(char *host, int clientPort);
+int SockOpen(const char *host, int clientPort);
/*
Get a string terminated by an '\n' (matches interface of fgets).