aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--smbtypes.h8
2 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 438d277f..2a7b3401 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,8 @@ noinst_LIBRARIES= libfm.a
libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
servport.c ntlm.h smbbyteorder.h smbdes.h smbmd4.h \
smbencrypt.h smbdes.c smbencrypt.c smbmd4.c smbutil.c \
- libesmtp/gethostbyname.h libesmtp/gethostbyname.c
+ libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
+ smbtypes.h
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)
diff --git a/smbtypes.h b/smbtypes.h
new file mode 100644
index 00000000..bdc26029
--- /dev/null
+++ b/smbtypes.h
@@ -0,0 +1,8 @@
+#ifndef SMBTYPES_H
+#define SMBTYPES_H
+
+typedef unsigned short uint16;
+typedef unsigned int uint32;
+typedef unsigned char uint8;
+
+#endif