diff options
-rw-r--r-- | NEWS | 6 | ||||
-rw-r--r-- | configure.ac | 2 | ||||
-rw-r--r-- | env.c | 4 |
3 files changed, 7 insertions, 5 deletions
@@ -91,6 +91,12 @@ fetchmail-6.4.3 (WIP) with OpenSSL lacks TLS v1.3 support. * If the trust anchor is missing, fetchmail refers the user to README.SSL. +## INTERNAL CHANGES: +* The AC_DECLS(getenv) check was removed, its only user was broken and not + accounting for that AC_DECLS always defines HAVE_DECL_... to 0 or 1, so + fetchmail never declared a missing getenv() symbol (it was testing with + #ifdef). Remove the backup declaration. getenv is mandated by SUSv2 anyways. + fetchmail-6.4.2 (released 2020-02-14, 27473 LoC): ## BREAKING CHANGES: diff --git a/configure.ac b/configure.ac index 4990fe49..ccca38d6 100644 --- a/configure.ac +++ b/configure.ac @@ -180,7 +180,7 @@ AC_CHECK_FUNCS(tcsetattr stty setsid geteuid seteuid dnl atexit inet_aton strftime setrlimit socketpair dnl sigaction strdup setlocale) -AC_CHECK_DECLS([strerror,getenv]) +AC_CHECK_DECLS([strerror]) dnl INET6 is used by KAME/getnameinfo AC_CACHE_CHECK(for AF_INET6/PF_INET6,ac_cv_inet6, AC_COMPILE_IFELSE([ @@ -31,10 +31,6 @@ #endif #include <limits.h> -#ifndef HAVE_DECL_GETENV -extern char *getenv(const char *); /* needed on sysV68 R3V7.1. */ -#endif - void envquery(int argc, char **argv) /* set up basic stuff from the environment (including the rc file name) */ { |