aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in47
-rw-r--r--NEWS8
-rw-r--r--configure.in35
3 files changed, 32 insertions, 58 deletions
diff --git a/Makefile.in b/Makefile.in
index 904ed38b..e6f1abe8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -6,8 +6,6 @@
PACKAGE = fetchmail
VERSION = 5.7.2
-SUBDIRS = @POSUB@
-
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
VPATH = @srcdir@
@@ -29,31 +27,30 @@ CEFLAGS = @CEFLAGS@
CPFLAGS = @CPFLAGS@
LDEFLAGS = @LDEFLAGS@
-INTLDEPS = @INTLDEPS@
-INTLLIBS = @INTLLIBS@
-INTLOBJS = @INTLOBJS@
+# for gettext (used by fetchmail.c, NOT by GNU gettext)
+localedir = $(datadir)/locale
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
# See also `config.h'.
-DEFS = @DEFS@ @EXTRADEFS@
+DEFS = @DEFS@ @EXTRADEFS@ -DLOCALEDIR=\"$(localedir)\"
# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
defines = $(DEFS)
# If your system needs extra libraries loaded in, define them here.
# In particular, add -lresolv if you are running bind 4.9.5
-LOADLIBS = @LIBS@ @LEXLIB@
+LOADLIBS = @LIBS@ @INTLLIBS@ @LEXLIB@
# LOADLIBS = -lsocket3r -lunix3r # QNX
# Any extra object files your system needs.
-extras = @LIBOBJS@ $(INTLDEPS)
+extras = @LIBOBJS@
# Extra sources/objects for library functions not provided on the host system.
EXTRASRC = @EXTRASRC@
# EXTRASRC = $(srcdir)/strcasecmp.c $(srcdir)/getopt.c $(srcdir)/getopt1.c $(srcdir)/alloca.c # QNX
-EXTRAOBJ = @EXTRAOBJ@
+EXTRAOBJ = @EXTRAOBJ@ @INTLOBJS@
# EXTRAOBJ = strcasecmp.o getopt.o getopt1.o alloca.o
DESTDIR =
@@ -125,15 +122,15 @@ all: fetchmail po
# Some makes apparently use .PHONY as the default goal if it is before `all'.
.PHONY: all
-fetchmail: $(objs)
+fetchmail: $(objs) @INTLDEPS@
$(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
-po: dummy
- @POMAKE@
+intl:
+@INTLDEPS@: dummy
+ $(MAKE) -C intl
-$(INTLDEPS): dummy
- @echo "Making $@ in intl"; \
- cd intl; $(MAKE) || exit 1
+po: dummy
+ $(MAKE) -C po
dummy:
@@ -151,7 +148,7 @@ netrc: netrc.c xmalloc.o error.o
$(CC) -DSTANDALONE -DHAVE_CONFIG_H -I. -g -o $@ $^
.c.o:
- $(CC) $(defines) -c $(CPFLAGS) -I. -I$(srcdir) $(CEFLAGS) $(CFLAGS) $<
+ $(CC) $(defines) -c $(CPFLAGS) -I. -I$(srcdir) -I../intl -I$(top_srcdir)/intl $(CEFLAGS) $(CFLAGS) $<
# For some losing Unix makes.
SHELL = /bin/sh
@@ -176,29 +173,33 @@ install:
rm -f $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
cd $(DESTDIR)$(mandir) && ln -s fetchmail.$(manext) fetchmailconf.$(manext)
@echo "Installing language catalogs..."
- @POMAKE@ install
+ -$(MAKE) -C intl install
+ $(MAKE) -C po install
uninstall:
rm -f $(DESTDIR)$(bindir)/fetchmail $(DESTDIR)$(bindir)/fetchmailconf
rm -f $(DESTDIR)$(mandir)/fetchmail.$(manext) $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
- @POMAKE@ uninstall
+ -$(MAKE) -C intl uninstall
+ $(MAKE) -C po uninstall
.PHONY: clean realclean distclean mostlyclean
clean:
- @POMAKE@ clean
+ -$(MAKE) -C intl clean
+ #work around braindamage in GNU gettext
+ -rm -f intl/libintl.h
+ -$(MAKE) -C po clean
-rm -f fetchmail *.o core fetchmail.dvi \
rcfile_l.c rcfile_y.h rcfile_y.c \
fetchmail.tar fetchmail.tar.gz \
netrc rfc822 unmime fetchmail-man.html
distclean: clean
- @POMAKE@ distclean
- rm -f po/*.gmo
+ -$(MAKE) -C intl distclean
+ -$(MAKE) -C po distclean
-rm -f Makefile config.h TAGS tags
-rm -f config.cache config.status config.log stamp-config
realclean: distclean
- @POMAKE@ clean
-rm -f FAQ FEATURES NOTES MANIFEST
-rm -f config.cache config.log Makefile
-rm -f fetchmail-*.tar.gz fetchmail-*.i386.rpm
@@ -305,7 +306,7 @@ fetchmail-man.html: fetchmail.man
# Make distribution, update LSM with proper size, remake distribution
# (Making fetchmail-man.html is a kluge to ensure that it will be
# available when I upload the distribution.)
-dist: Makefile.in distdocs
+dist: distclean Makefile.in distdocs
rm -f MANIFEST; make MANIFEST;
touch fetchmail.lsm
make fetchmail-$(VERSION).tar.gz
diff --git a/NEWS b/NEWS
index 4cadf2f2..78a902c7 100644
--- a/NEWS
+++ b/NEWS
@@ -3,9 +3,11 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
* Incorporate SA_LEN patch from Red Hat.
-* HMH's "no spambounce" patch for fetchmaiolconf.
-* John Bartlett's patch to make the driver code more tolerant of flaky POP3
- servers.
+* HMH's "no spambounce" patch for fetchmailconf.
+* John Bartlett's patch to make the driver code more tolerant of flaky POP3
+ servers (better handling of timeout at session start).
+* Make `fetchmail --configdump' work when there's a defaults entry.
+* Incorporated HMH's build fixes.
fetchmail-5.7.2 (Sun Mar 4 19:05:57 EST 2001), 20167 lines:
diff --git a/configure.in b/configure.in
index 6c7a2e71..c69d4d76 100644
--- a/configure.in
+++ b/configure.in
@@ -34,8 +34,6 @@ AC_SUBST(CPFLAGS)
AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
-AC_SUBST(POMAKE)
-AC_SUBST(LOCALE_DIR)
PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
@@ -70,12 +68,10 @@ then
LDFLAGS=`echo $LDFLAGS | sed "s/-s //"`
fi
-# i18n
+dnl i18n
ALL_LINGUAS="cs es fr pl pt_BR gl da"
-
AM_GNU_GETTEXT
-
-# end i18n
+dnl end i18n
# Under sysV68, socket and friends are provided by the C library.
# -linet does not provide socket, but causes multiple definition
@@ -86,16 +82,6 @@ AC_CHECK_FUNC(socket,
AC_CHECK_LIB(socket,socket)
AC_CHECK_LIB(inet,socket))
-# If gettext isn't in the C library, maybe there's a -lintl. However,
-# do not check if user has specified --with-included-gettext. On
-# some systems (e.g. Solaris), there is a gettext in libc which
-# we do not want to use if --with-included-gettext is specified.
-if test x$nls_cv_force_use_gnu_gettext != xyes; then
- AC_CHECK_FUNC(gettext,
- AC_MSG_RESULT(using libc's gettext),
- AC_CHECK_LIB(intl,gettext))
-fi
-
# The condition in this test copes with the presence of inet_addr in libc6.
AC_CHECK_FUNC(inet_addr,
AC_MSG_RESULT(using libc's inet_addr),
@@ -224,21 +210,6 @@ AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
-if test "$USE_NLS" = "yes"
-then
- echo 'Enabling internationalization support...'
- POMAKE='cd po; $(MAKE)'
- if test "x$prefix" != xNONE; then
- LOCALE_DIR=$prefix/share/locale
- else
- LOCALE_DIR=$ac_default_prefix/share/locale
- fi
- EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"${LOCALE_DIR}\"'"
-else
- echo 'Disabling internationalization support...'
- POMAKE="@echo '(NLS support disabled)'; #"
-fi
-
### use option --enable-POP2 to compile in the POP2 support
AC_ARG_ENABLE(POP2,
[ --enable-POP2 compile in POP2 protocol support (obsolete)],
@@ -625,7 +596,7 @@ then
fi
fi])
-AC_OUTPUT([Makefile po/Makefile.in], [
+AC_OUTPUT([Makefile intl/Makefile po/Makefile.in], [
# The reason for this odd makedepend line is that we want
# to have all dependencies evaluated relative to the source directory
# and let VPATH do all the dirty work when we build remotely