aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS4
-rw-r--r--configure.in2
-rwxr-xr-xindexgen.sh4
-rw-r--r--socket.c1
4 files changed, 8 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 0abdc0db..c80e81b4 100644
--- a/NEWS
+++ b/NEWS
@@ -9,6 +9,10 @@ a Certifying Authority we recognize?).
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* Added FAQ item R10 on timeouts during messages.
+* Fixed indentation problem in fetchmailconf.
+* Federico Schwindt's patch to fix broken SSL configuration.
+
fetchmail-5.2.0 (Tue Nov 30 14:24:25 EST 1999), 18302 lines:
* fetchmailconf now complains and exits gracefully when not run under X.
* configure.in port patch for OpenBSD from Federico G. Schwindt.
diff --git a/configure.in b/configure.in
index 3e438586..ca4addea 100644
--- a/configure.in
+++ b/configure.in
@@ -361,7 +361,7 @@ AC_ARG_WITH(ssl,
[ --with-ssl=[DIR] enable SSL support using libraries in DIR],
[with_ssl=$withval],
[with_ssl=no])
-test "$with_netsec" = "yes" && AC_DEFINE(SSL_ENABLE)
+test "$with_ssl" = "yes" && AC_DEFINE(SSL_ENABLE)
if test "$with_ssl" = "yes"
then
diff --git a/indexgen.sh b/indexgen.sh
index 1c9b8120..1a963f90 100755
--- a/indexgen.sh
+++ b/indexgen.sh
@@ -2,8 +2,8 @@
#
# indexgen.sh -- generate current version of fetchmail home page.
#
-goldvers="5.1.0"
-goldname="5.1.0"
+goldvers="5.2.0"
+goldname="5.2.0"
version=`sed -n <Makefile.in "/VERSION *= */s/VERSION *= *\([^ ]*\)/\1/p"`
date=`date "+%d %b %Y"`
diff --git a/socket.c b/socket.c
index 12cc56c7..09237d2f 100644
--- a/socket.c
+++ b/socket.c
@@ -126,6 +126,7 @@ int SockOpen(const char *host, const char *service, const char *options,
void *request = NULL;
int requestlen;
#endif /* NET_SECURITY */
+ int i;
#ifdef HAVE_SOCKETPAIR
if (plugin)