aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS7
-rw-r--r--driver.c6
-rw-r--r--rcfile_y.y6
4 files changed, 14 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index 3fe8693e..a5042ff4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.8.9
+VERSION = 5.8.10
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 908937cc..e719a2df 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,13 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+fetchmail-5.8.10 (Mon Jun 25 17:04:08 EDT 2001), 20922 lines:
+
+* More fixes for the new message-marking code from Thomas Moestl.
+* Fixes for ODMR code from Matt Armstrong.
+
+There are 355 people on fetchmail-friends and on fetchmail-announce.
+
fetchmail-5.8.9 (Sun Jun 24 20:30:49 EDT 2001), 20922 lines:
* HMH's snprintf/strncat cleanup patch.
diff --git a/driver.c b/driver.c
index 3e8dc3bc..43772458 100644
--- a/driver.c
+++ b/driver.c
@@ -606,7 +606,7 @@ static int fetch_messages(int mailserver_socket, struct query *ctl,
struct idlist *sdp;
for (sdp = ctl->newsaved; sdp; sdp = sdp->next)
- if ((sdp->val.status.num == num) && (msgcodes[num-1] > 0))
+ if ((sdp->val.status.num == num) && (msgcodes[num-1] >= 0))
{
sdp->val.status.mark = UID_SEEN;
save_str(&ctl->oldsaved, sdp->id,UID_SEEN);
@@ -621,7 +621,7 @@ static int fetch_messages(int mailserver_socket, struct query *ctl,
}
else if (ctl->server.base_protocol->delete
&& !suppress_delete
- && ((msgcodes[num-1] > 0) ? !ctl->keep : ctl->flush))
+ && ((msgcodes[num-1] >= 0) ? !ctl->keep : ctl->flush))
{
(*deletions)++;
if (outlevel > O_SILENT)
@@ -1174,7 +1174,7 @@ is restored."));
xalloca(msgsizes, int *, sizeof(int) * count);
xalloca(msgcodes, int *, sizeof(int) * count);
for (i = 0; i < count; i++)
- msgcodes[num - 1] = MSGLEN_UNKNOWN;
+ msgcodes[i] = MSGLEN_UNKNOWN;
/*
* We need the size of each message before it's
diff --git a/rcfile_y.y b/rcfile_y.y
index dbb1ad38..e034d566 100644
--- a/rcfile_y.y
+++ b/rcfile_y.y
@@ -286,8 +286,8 @@ smtp_list : STRING {save_str(&current.smtphunt, $1,TRUE);}
| smtp_list STRING {save_str(&current.smtphunt, $2,TRUE);}
;
-domain_list : STRING {save_str(&current.domainlist, $1,TRUE);}
- | domain_list STRING {save_str(&current.domainlist, $2,TRUE);}
+fetch_list : STRING {save_str(&current.domainlist, $1,TRUE);}
+ | fetch_list STRING {save_str(&current.domainlist, $2,TRUE);}
;
num_list : NUMBER
@@ -313,7 +313,7 @@ user_option : TO localnames HERE
| PASSWORD STRING {current.password = xstrdup($2);}
| FOLDER folder_list
| SMTPHOST smtp_list
- | FETCHDOMAINS domain_list
+ | FETCHDOMAINS fetch_list
| SMTPADDRESS STRING {current.smtpaddress = xstrdup($2);}
| SMTPNAME STRING {current.smtpname = xstrdup($2);}
| SPAMRESPONSE num_list