aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL8
-rw-r--r--configure.in25
2 files changed, 24 insertions, 9 deletions
diff --git a/INSTALL b/INSTALL
index 50c6cd7c..55737d31 100644
--- a/INSTALL
+++ b/INSTALL
@@ -32,7 +32,13 @@ leaving it out cuts the executable's size slightly.
Specifying --with-kerberos=DIR will tell the fetchmail build process to
look in DIR for Kerberos support. Configure normally looks in /usr/kerberos
-and /usr/athena; if you specify this option it will look in DIR first.
+and /usr/athena; if you specify this option with an argument it will look
+in DIR first.
+
+Unfortunately, there doesn't seem to be good standardization of where
+Kerberos lives. If your configuration doesn't match one of the four
+that fetchmail's configure.in knows about, you may find you have to
+hand-hack the Makefile a bit.
If you want to build for debugging,
diff --git a/configure.in b/configure.in
index bb783bdd..5939a046 100644
--- a/configure.in
+++ b/configure.in
@@ -128,16 +128,25 @@ test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
AC_ARG_WITH(kerberos,
[ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])
-for dir in $with_kerberos /usr/kerberos /usr/kerberosIV /usr/athena
-do
- if test -f "$dir/include/krb.h"
- then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
+# The "then" arm (nonempty $with_kerberos) is kind of a crock. It works for
+# configuring the BSD/OS Kerberos IV support, though.
+if test -n "$with_kerberos"
+then
+ CFLAGS="$CFLAGS -DKERBEROS_V4 -I$with_kerberos"
LDFLAGS="$LDFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
- break
- fi
-done
+else
+ for dir in /usr/kerberos /usr/kerberosIV /usr/athena
+ do
+ if test -f "$dir/include/krb.h"
+ then
+ CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
+ LDFLAGS="$LDFLAGS -L$dir/lib"
+ LIBS="$LIBS -lkrb -ldes"
+ break
+ fi
+ done
+fi
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,