aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--configure.ac1
2 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 973bf400..3947beaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,10 @@ libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
smbtypes.h fm_getaddrinfo.c tls.c rfc822valid.c \
xmalloc.h sdump.h sdump.c x509_name_match.c \
- fm_strl.h ntlmsubr.c
+ fm_strl.h
+if NTLM_ENABLE
+libfm_a_SOURCES += ntlmsubr.c
+endif
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)
diff --git a/configure.ac b/configure.ac
index c768244f..37103116 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,6 +443,7 @@ AC_ARG_ENABLE(NTLM,
[with_NTLM=$enableval],
[with_NTLM=no])
test "$with_NTLM" = "yes" && AC_DEFINE(NTLM_ENABLE,1,Define if you want NTLM authentication)
+AM_CONDITIONAL(NTLM_ENABLE, test "$with_NTLM" = yes)
### use option --enable-SDPS to compile in the SDPS support
AC_ARG_ENABLE(SDPS,