aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL4
-rw-r--r--configure.in28
2 files changed, 18 insertions, 14 deletions
diff --git a/INSTALL b/INSTALL
index 5581f54f..50c6cd7c 100644
--- a/INSTALL
+++ b/INSTALL
@@ -30,6 +30,10 @@ and there don't seem to be any live servers for it anymore. You can
configure it back in if you want with `configure --enable-POP2', but
leaving it out cuts the executable's size slightly.
+Specifying --with-kerberos=DIR will tell the fetchmail build process to
+look in DIR for Kerberos support. Configure normally looks in /usr/kerberos
+and /usr/athena; if you specify this option it will look in DIR first.
+
If you want to build for debugging,
CFLAGS=-g LDFLAGS=" " ./configure
diff --git a/configure.in b/configure.in
index d98ceff8..2b0d8933 100644
--- a/configure.in
+++ b/configure.in
@@ -55,20 +55,6 @@ then
EXTRAOBJ="$EXTRAOBJ alloca.o"
fi
-if test -f "/usr/kerberos/include/krb.h"
-then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I/usr/kerberos/include"
- LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
- LIBS="$LIBS -lkrb -ldes"
-fi
-
-if test -f "/usr/athena/include/krb.h"
-then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I/usr/athena/include"
- LDFLAGS="$LDFLAGS -L/usr/athena/lib"
- LIBS="$LIBS -lkrb -ldes"
-fi
-
dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
@@ -138,6 +124,20 @@ AC_ARG_ENABLE(POP2,
[with_POP2=no])
test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+### use option --with-kerberos=DIR to point at a Kerberos directory
+AC_ARG_WITH(kerberos,
+ [ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])
+
+for dir in $with_kerberos /usr/kerberos /usr/athena
+do
+ if test -f "$dir/include/krb.h"
+ then
+ CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
+ LDFLAGS="$LDFLAGS -L$dir/lib"
+ LIBS="$LIBS -lkrb -ldes"
+ fi
+done
+
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.