aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in9
-rw-r--r--driver.c17
2 files changed, 24 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index d62d7440..24ca45e6 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -10,6 +10,7 @@ srcdir = @srcdir@
VPATH = @srcdir@
CC = @CC@
+# CC = cc # QNX
CFLAGS = @CFLAGS@
# CFLAGS = -g2 -5 # QNX
@@ -18,6 +19,7 @@ LDFLAGS = @LDFLAGS@
LEX = @LEX@
LEXFLAGS=
YACC = @YACC@
+# YACC = yacc
YACCFLAGS = -dt
# How to invoke ranlib. This is only used by the `glob' subdirectory.
@@ -25,8 +27,9 @@ RANLIB = @RANLIB@
# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
# See also `config.h'.
-defines = -DRELEASE_ID=\"$(VERS)\" @DEFS@
-# defines = -DHAVE_CONFIG_H -DQNX -DHAVE_UNISTD_H -DSTDC_HEADERS # QNX
+DEFS = @DEFS@
+# DEFS = -DHAVE_CONFIG_H -DQNX -DHAVE_UNISTD_H -DSTDC_HEADERS # QNX
+defines = -DRELEASE_ID=\"$(VERS)\" $(DEFS)
# If your system needs extra libraries loaded in, define them here.
LOADLIBS = @LIBS@ @LEXLIB@
@@ -37,7 +40,9 @@ extras = @LIBOBJS@
# Extra sources/objects for library functions not provided on the host system.
EXTRASRC = @EXTRASRC@
+# EXTRASRC = $(srcdir)/strcasecmp.c $(srcdir)/getopt.c $(srcdir)/getopt1.c $(srcdir)/alloca.c # QNX
EXTRAOBJ = @EXTRAOBJ@
+# EXTRAOBJS = strcasecmp.o getopt.o getopt1.o alloca.o
# Common prefix for machine-independent installed files.
prefix = @prefix@
diff --git a/driver.c b/driver.c
index a52ffe24..715607e3 100644
--- a/driver.c
+++ b/driver.c
@@ -14,7 +14,11 @@
#include <config.h>
#include <stdio.h>
#include <stdlib.h>
+#ifdef QNX
+#include <stdarg.h>
+#else
#include <varargs.h>
+#endif
#include <sys/time.h>
#include <signal.h>
#include <string.h>
@@ -842,10 +846,15 @@ closeUp:
globals: reads outlevel.
*********************************************************************/
+#if defined(QNX)
+void gen_send(int socket, char *fmt, ... )
+{
+#else
void gen_send(socket, fmt, va_alist)
int socket;
const char *fmt;
va_dcl {
+#endif
char buf [POPBUFSIZE+1];
va_list ap;
@@ -855,7 +864,11 @@ va_dcl {
else
buf[0] = '\0';
+#if defined(QNX)
+ va_start(ap, fmt) ;
+#else
va_start(ap);
+#endif
vsprintf(buf + strlen(buf), fmt, ap);
va_end(ap);
@@ -899,7 +912,11 @@ va_dcl {
else
buf[0] = '\0';
+#if defined(QNX)
+ va_start(ap, fmt) ;
+#else
va_start(ap);
+#endif
vsprintf(buf + strlen(buf), fmt, ap);
va_end(ap);