aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--acconfig.h73
-rwxr-xr-xfetchmailconf82
-rwxr-xr-xindexgen.sh5
-rw-r--r--sink.c5
4 files changed, 83 insertions, 82 deletions
diff --git a/acconfig.h b/acconfig.h
index e4835691..4cb3b034 100644
--- a/acconfig.h
+++ b/acconfig.h
@@ -6,67 +6,71 @@
No software package will use all of them; autoheader copies the ones
your configure.in uses into your configuration header file templates.
- The entries are in sort -df order: alphabetical, case insensitive,
- ignoring punctuation (such as underscores). Although this order
- can split up related entries, it makes it easier to check whether
- a given entry is in the file.
-
Leave the following blank line there!! Autoheader needs it. */
/* Define to 1 if NLS is requested. */
#undef ENABLE_NLS
+/* Define if you have atexit */
+#undef HAVE_ATEXIT
+
/* Define as 1 if you have catgets and don't want to use GNU gettext. */
#undef HAVE_CATGETS
+/* Define if you have GNU's getopt family of functions. */
+#undef HAVE_GETOPTLONG
+
/* Define as 1 if you have gettext and don't want to use GNU gettext. */
#undef HAVE_GETTEXT
+/* Define if you have MIT kerberos */
+#undef HAVE_GSS_C_NT_HOSTBASED_SERVICE
+
/* Define if you have herror available in your bind library */
#undef HAVE_HERROR
/* Define if your locale.h file contains LC_MESSAGES. */
#undef HAVE_LC_MESSAGES
+/* Define if you have md5 in libc. */
+#undef HAVE_MD5
+
+/* Define if you have the memmove function. */
+#undef HAVE_MEMMOVE
+
+/* Define if you have on_exit */
+#undef HAVE_ON_EXIT
+
/* Define if you have res_search available in your bind library */
#undef HAVE_RES_SEARCH
-/* Define as 1 if you have the stpcpy function. */
-#undef HAVE_STPCPY
-
-/* Define if your C compiler allows void * as a function result */
-#undef HAVE_VOIDPOINTER
+/* Define if you have setrlimit */
+#undef HAVE_SETRLIMIT
-/* Define if your C compiler allows ANSI volatile */
-#undef HAVE_VOLATILE
+/* Define if you want built-in SOCKS support */
+#undef HAVE_SOCKS
-/* Define if `union wait' is the type of the first arg to wait functions. */
-#undef HAVE_UNION_WAIT
+/* Define as 1 if you have the stpcpy function. */
+#undef HAVE_STPCPY
/* Define if you have the strcasecmp function. */
#undef HAVE_STRCASECMP
-/* Define if you have the memmove function. */
-#undef HAVE_MEMMOVE
-
-/* Define if you have GNU's getopt family of functions. */
-#undef HAVE_GETOPTLONG
-
/* Define if you have strstr */
#undef HAVE_STRSTR
-/* Define if you have vsyslog */
-#undef HAVE_VSYSLOG
+/* Define if `union wait' is the type of the first arg to wait functions. */
+#undef HAVE_UNION_WAIT
-/* Define if you have atexit */
-#undef HAVE_ATEXIT
+/* Define if your C compiler allows void * as a function result */
+#undef HAVE_VOIDPOINTER
-/* Define if you have on_exit */
-#undef HAVE_ON_EXIT
+/* Define if your C compiler allows ANSI volatile */
+#undef HAVE_VOLATILE
-/* Define if you have setrlimit */
-#undef HAVE_SETRLIMIT
+/* Define if you have vsyslog */
+#undef HAVE_VSYSLOG
/* Define to the name of the distribution. */
#undef PACKAGE
@@ -79,12 +83,12 @@
#undef SIZEOF_SHORT
#undef SIZEOF_LONG
-/* Define if you want POP2 support compiled in */
-#undef POP2_ENABLE
-
/* Define if you want POP3 support compiled in */
#undef POP3_ENABLE
+/* Define if you want POP2 support compiled in */
+#undef POP2_ENABLE
+
/* Define if you want IMAP support compiled in */
#undef IMAP_ENABLE
@@ -118,15 +122,10 @@
/* Define if you have HEIMDAL kerberos 5 */
#undef HEIMDAL
-/* Define if you have MIT kerberos */
-#undef HAVE_GSS_C_NT_HOSTBASED_SERVICE
-
-/* Define if you want built-in SOCKS support */
-#undef HAVE_SOCKS
-
/* Define to the version of the distribution. */
#undef VERSION
+
/* Leave that blank line there!! Autoheader needs it.
If you're adding to this file, keep in mind:
diff --git a/fetchmailconf b/fetchmailconf
index b67892c5..000dcfa0 100755
--- a/fetchmailconf
+++ b/fetchmailconf
@@ -4,7 +4,7 @@
# by Eric S. Raymond, <esr@snark.thyrsus.com>.
# Requires Python with Tkinter, and the following OS-dependent services:
# posix, posixpath, socket
-version = "1.18"
+version = "1.19"
from Tkinter import *
from Dialog import *
@@ -116,7 +116,7 @@ class Server:
else: str = str + "skip"
str = str + (" " + self.pollname)
if self.via:
- str = str + (" via \"%s\"\n" % (self.via,));
+ str = str + (" via " + str(self.via) + "\n");
if self.protocol != ServerDefaults.protocol:
str = str + " with proto " + self.protocol
if self.port != defaultports[self.protocol] and self.port != 0:
@@ -131,7 +131,7 @@ class Server:
else:
str = str + " envelope " + self.envelope
if self.qvirtual:
- str = str + (" qvirtual \"%s\"\n" % (self.qvirtual,));
+ str = str + (" qvirtual " + str(self.qvirtual) + "\n");
if self.preauth != ServerDefaults.preauth:
str = str + " preauth " + self.preauth
if self.dns != ServerDefaults.dns or self.uidl != ServerDefaults.uidl:
@@ -159,11 +159,11 @@ class Server:
str = str + " "
if self.interface:
- str = str + "interface \"" + self.interface + "\""
+ str = str + "interface " + str(self.interface)
if self.monitor:
- str = str + "monitor \"" + self.monitor + "\""
+ str = str + "monitor " + str(self.monitor)
if self.netsec:
- str = str + "netsec \"" + self.netsec + "\""
+ str = str + "netsec " + str(self.netsec)
if self.interface or self.monitor or self.netsec:
if folded:
str = str + "\n"
@@ -257,15 +257,15 @@ class User:
('properties', 'String'))
def __repr__(self):
- str = " "
- str = str + "user \"" + self.remote + "\" there ";
+ res = " "
+ res = res + "user " + str(self.remote) + " there ";
if self.password:
- str = str + "with password \"" + self.password + '" '
+ res = res + "with password " + str(self.password) + " "
if self.localnames:
- str = str + "is"
+ res = res + "is"
for x in self.localnames:
- str = str + " " + x
- str = str + " here"
+ res = res + " " + x
+ res = res + " here"
if (self.keep != UserDefaults.keep
or self.flush != UserDefaults.flush
or self.fetchall != UserDefaults.fetchall
@@ -275,65 +275,65 @@ class User:
or self.pass8bits != UserDefaults.pass8bits
or self.mimedecode != UserDefaults.mimedecode
or self.dropstatus != UserDefaults.dropstatus):
- str = str + " options"
+ res = res + " options"
if self.keep != UserDefaults.keep:
- str = str + flag2str(self.keep, 'keep')
+ res = res + flag2str(self.keep, 'keep')
if self.flush != UserDefaults.flush:
- str = str + flag2str(self.flush, 'flush')
+ res = res + flag2str(self.flush, 'flush')
if self.fetchall != UserDefaults.fetchall:
- str = str + flag2str(self.fetchall, 'fetchall')
+ res = res + flag2str(self.fetchall, 'fetchall')
if self.rewrite != UserDefaults.rewrite:
- str = str + flag2str(self.rewrite, 'rewrite')
+ res = res + flag2str(self.rewrite, 'rewrite')
if self.forcecr != UserDefaults.forcecr:
- str = str + flag2str(self.forcecr, 'forcecr')
+ res = res + flag2str(self.forcecr, 'forcecr')
if self.stripcr != UserDefaults.stripcr:
- str = str + flag2str(self.stripcr, 'stripcr')
+ res = res + flag2str(self.stripcr, 'stripcr')
if self.pass8bits != UserDefaults.pass8bits:
- str = str + flag2str(self.pass8bits, 'pass8bits')
+ res = res + flag2str(self.pass8bits, 'pass8bits')
if self.mimedecode != UserDefaults.mimedecode:
- str = str + flag2str(self.mimedecode, 'mimedecode')
+ res = res + flag2str(self.mimedecode, 'mimedecode')
if self.dropstatus != UserDefaults.dropstatus:
- str = str + flag2str(self.dropstatus, 'dropstatus')
+ res = res + flag2str(self.dropstatus, 'dropstatus')
if self.limit != UserDefaults.limit:
- str = str + " limit " + `self.limit`
+ res = res + " limit " + `self.limit`
if self.warnings != UserDefaults.warnings:
- str = str + " warnings " + `self.warnings`
+ res = res + " warnings " + `self.warnings`
if self.fetchlimit != UserDefaults.fetchlimit:
- str = str + " fetchlimit " + `self.fetchlimit`
+ res = res + " fetchlimit " + `self.fetchlimit`
if self.batchlimit != UserDefaults.batchlimit:
- str = str + " batchlimit " + `self.batchlimit`
+ res = res + " batchlimit " + `self.batchlimit`
if self.ssl != UserDefaults.ssl:
- str = str + flag2str(self.ssl, 'ssl')
+ res = res + flag2str(self.ssl, 'ssl')
if self.sslkey != UserDefaults.sslkey:
- str = str + " sslkey " + `self.sslkey`
+ res = res + " sslkey " + `self.sslkey`
if self.sslcert != UserDefaults.sslcert:
- str = str + " ssl " + `self.sslcert`
+ res = res + " ssl " + `self.sslcert`
if self.expunge != UserDefaults.expunge:
- str = str + " expunge " + `self.expunge`
- str = str + "\n"
+ res = res + " expunge " + `self.expunge`
+ res = res + "\n"
trimmed = self.smtphunt;
if trimmed != [] and trimmed[len(trimmed) - 1] == "localhost":
trimmed = trimmed[0:len(trimmed) - 1]
if trimmed != [] and trimmed[len(trimmed) - 1] == hostname:
trimmed = trimmed[0:len(trimmed) - 1]
if trimmed != []:
- str = str + " smtphost "
+ res = res + " smtphost "
for x in trimmed:
- str = str + " " + x
- str = str + "\n"
+ res = res + " " + x
+ res = res + "\n"
if self.mailboxes:
- str = str + " folder"
+ res = res + " folder"
for x in self.mailboxes:
- str = str + " " + x
- str = str + "\n"
+ res = res + " " + x
+ res = res + "\n"
for fld in ('smtpaddress', 'preconnect', 'postconnect', 'mda', 'bsmtp', 'properties'):
if getattr(self, fld):
- str = str + " %s %s\n" % (fld, `getattr(self, fld)`)
+ res = res + " %s %s\n" % (fld, `getattr(self, fld)`)
if self.lmtp != UserDefaults.lmtp:
- str = str + flag2str(self.lmtp, 'lmtp')
+ res = res + flag2str(self.lmtp, 'lmtp')
if self.antispam != UserDefaults.antispam:
- str = str + " antispam " + self.antispam + "\n"
- return str;
+ res = res + " antispam " + self.antispam + "\n"
+ return res;
def __str__(self):
return "[User: " + repr(self) + "]"
diff --git a/indexgen.sh b/indexgen.sh
index 1a963f90..77e5cd0a 100755
--- a/indexgen.sh
+++ b/indexgen.sh
@@ -96,7 +96,8 @@ not a full-time "push" connection.<p>
Fetchmail is easy to configure. You can edit its dotfile directly, or
use the interactive GUI configurator (fetchmailconf) supplied with the
-fetchmail distribution.<P>
+fetchmail distribution. It is also directly supported in linuxconf
+versions 1.16r8 and later.<P>
Fetchmail is fast and lightweight. It packs all its standard
features (POP3, IMAP, and ETRN support) in ${fetchmailsize}K of core on a
@@ -190,7 +191,7 @@ FAQ covers them like a blanket.<P>
Fetchmail was written and is maintained by <a
href="../index.html">Eric S. Raymond</a>. There are some designated
backup maintainers (<a href="mailto:funk+@osu.edu">Rob Funk</a>, <a
-href="mailto:alberty@apexxtech.com">Al Youngwerth</a>, <a
+href="mailto:alberty@allnix.com">Al Youngwerth</a>, <a
href="mailto:imdave@mcs.net">Dave Bodenstab</a>). Other backup
maintainers may be added in the future, in order to ensure continued
support should Eric S. Raymond drop permanently off the net for any
diff --git a/sink.c b/sink.c
index e3cb4a8f..3a001f7a 100644
--- a/sink.c
+++ b/sink.c
@@ -500,7 +500,8 @@ int open_sink(struct query *ctl, struct msgblk *msg,
else if (ctl->mimemsg & MSG_IS_7BIT)
fputs(" BODY=7BIT", sinkfp);
- fprintf(sinkfp, " SIZE=%d\r\n", msg->reallen);
+ /* exim's BSMTP processor does not handle SIZE */
+ /* fprintf(sinkfp, " SIZE=%d\r\n", msg->reallen); */
/*
* RFC 1123 requires that the domain name part of the
@@ -866,7 +867,7 @@ int close_sink(struct query *ctl, struct msgblk *msg, flag forward)
else if (ctl->bsmtp)
{
/* implicit disk-full check here... */
- fputs("..\r\n", sinkfp);
+ fputs(".\r\n", sinkfp);
if (strcmp(ctl->bsmtp, "-"))
fclose(sinkfp);
if (ferror(sinkfp))