aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--NEWS5
-rw-r--r--RELEASE-INSTRUCTIONS1
-rw-r--r--configure.ac2
-rwxr-xr-xdist-tools/makerelease.pl6
-rw-r--r--genlsm.sh.in33
-rwxr-xr-xspecgen.sh3
7 files changed, 6 insertions, 48 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f247dae..d6e27845 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -222,10 +222,6 @@ dist-hook:
cd $(distdir) && find $(distdirs) po -name .git -type d -prune -exec rm -rf '{}' ';'
cd $(distdir) && find $(distdirs) po -name '*~' -exec rm -f '{}' ';'
-.PHONY: lsm
-lsm: genlsm.sh dist
- $(SHELL) genlsm.sh >$(PACKAGE)-$(VERSION).lsm
-
# this target expects a .rsyncs file with lines of this format:
# host:directory/
# it will call rsync from its source directory to the destination for
diff --git a/NEWS b/NEWS
index bd9bd130..d78cdcfd 100644
--- a/NEWS
+++ b/NEWS
@@ -56,13 +56,16 @@ removed from a 6.4.0 or newer release.)
--------------------------------------------------------------------------------
-fetchmail-6.3.24 (not yet released):
+fetchmail-6.3.24 (released 2012-12-23, 26108 LoC):
# NOTE THAT THE RELEASE OF FUTURE FETCHMAIL 6.3.X VERSIONS IS UNCLEAR.
Should a 7.0 release be made earlier, chances are that the 6.3.X branch
is abandoned and its changes be folded into the 7.0 release, with changes
after 6.3.24 not available on their own in a newer 6.3.X release.
+# NOTE THAT FETCHMAIL IS NO LONGER PUBLISHED THROUGH IBIBLIO.
+ They have stopped accepting submissions and consider themselves an archive.
+
# CRITICAL AND REGRESSION FIXES
* Plug a memory leak in OpenSSL's certificate verification callback.
This would affect fetchmail configurations running with SSL in daemon mode
diff --git a/RELEASE-INSTRUCTIONS b/RELEASE-INSTRUCTIONS
index f9708f6c..e5d83be7 100644
--- a/RELEASE-INSTRUCTIONS
+++ b/RELEASE-INSTRUCTIONS
@@ -14,7 +14,6 @@ To do a release:
- These would be done automatically by makerelease.pl:
- Upload sig and tarball to ~/public_html/fetchmail/
- Upload sig and tarball to ftp.berlios.de:/incoming/ and release
- - Upload lsm, sig and tarball to ibiblio.org:/incoming/linux/
- Update the fetchmail website for version, link to release nodes
(update release_id) and last update, commit, and upload.
diff --git a/configure.ac b/configure.ac
index f012c7a9..c379ccb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -968,7 +968,7 @@ if test "$needtrio" = 1 ; then
fi
dnl ----------------------------------------------------------------'
-AC_CONFIG_FILES([Makefile po/Makefile.in genlsm.sh])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_OUTPUT
dnl Local Variables:
diff --git a/dist-tools/makerelease.pl b/dist-tools/makerelease.pl
index 86e9ad71..51b82854 100755
--- a/dist-tools/makerelease.pl
+++ b/dist-tools/makerelease.pl
@@ -100,7 +100,7 @@ if (system("mkdir -p autobuild && cd autobuild "
print "### Test-building the software...\n";
if (system("cd autobuild && make -s clean"
- . " && make " . ($verbose ? '' : '-s') . " check distcheck lsm")) {
+ . " && make " . ($verbose ? '' : '-s') . " check distcheck")) {
die("Compilation failure\n");
}
@@ -177,10 +177,6 @@ print "=== local\n";
system("cp", "autobuild/$project-$version$distsufx", "autobuild/$project-$version$distsufx.asc", "$ENV{HOME}/public_html/fetchmail/") and die "Cannot upload to \$HOME/public_html/fetchmail/: $!";
-print "=== ibiblio\n";
-
-system("lftp -e \"lcd autobuild ; mput $project-$version$distsufx $project-$version$distsufx.asc $project-$version.lsm ; quit\" ibiblio.org:/incoming/linux/") and warn "Upload to ibiblio failed: $!";
-
print "=== berlios\n";
system("lftp -e \"lcd autobuild ; mput $project-$version$distsufx $project-$version$distsufx.asc ; quit\" ftp.berlios.de:/incoming/") and warn "Upload to berlios failed: $!";
diff --git a/genlsm.sh.in b/genlsm.sh.in
deleted file mode 100644
index 52834287..00000000
--- a/genlsm.sh.in
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /bin/sh
-# @configure_input@
-
-# WARNING:
-# WARNING: If you change the description, also change specgen.sh!
-# WARNING:
-
-cat <<EOF
-Begin4
-Title: @PACKAGE@
-Version: @VERSION@
-Entered-date: `date -u +%Y-%m-%d`
-Description: Fetchmail is a free, full-featured, robust, and well-documented
- remote mail retrieval and forwarding utility intended to be used
- over on-demand TCP/IP links (such as SLIP or PPP connections).
- It retrieves mail from remote mail servers and forwards it
- to your local (client) machine's delivery system, so it can
- then be be read by normal mail user agents such as mutt, elm,
- pine, (x)emacs/gnus, or mailx. Comes with an interactive GUI
- configurator (in Python/Tk) suitable for end-users.
-Keywords: mail, client, POP3, APOP, KPOP, IMAP, ETRN, ODMR, SMTP, ESMTP, GSSAPI, RPA, NTLM, CRAM-MD5, SASL
-Author: matthias.andree@gmx.de (Matthias Andree)
- shetye@bombay.retortsoft.com (Sunil Shetye)
- rfunk@funknet.net (Rob Funk)
-Maintained-by: fetchmail-devel@lists.berlios.de
-Primary-site: http://developer.berlios.de/projects/fetchmail
- `ls -sk @PACKAGE@-@VERSION@.tar.bz2 | \
- @AWK@ '{ printf "%4dkB", $1 }'` @PACKAGE@-@VERSION@.tar.bz2
- 1kB @PACKAGE@-@VERSION@.tar.bz2.asc
-Platforms: All
-Copying-policy: GPL
-End
-EOF
diff --git a/specgen.sh b/specgen.sh
index 7aa0fa80..e2448c12 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -1,8 +1,5 @@
#!/bin/sh
-# WARNING:
-# WARNING: If you change the description, also change genlsm.sh.in!
-# WARNING:
version="$1"
set -e