aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS2
-rw-r--r--fetchmail.h8
-rw-r--r--rcfile_l.l2
4 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 69584a12..fa8c1905 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,7 +3,7 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=2.4
+VERS=2.5
PL=0
# Ultrix 2.2 make doesn't expand the value of VPATH.
diff --git a/NEWS b/NEWS
index 3cbb84ba..b307e33a 100644
--- a/NEWS
+++ b/NEWS
@@ -10,7 +10,7 @@
Release Notes:
------------------------------------------------------------------------------
-fetchmail-2.5 ()
+fetchmail-2.5 (Mon Dec 23 04:18:54 EST 1996)
features --
diff --git a/fetchmail.h b/fetchmail.h
index 5fa4053a..994bc690 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -142,6 +142,10 @@ extern int quitmode; /* if --quit was set */
extern int check_only; /* if --check was set */
extern int cmd_batchlimit; /* if --batchlimit was set */
extern char *cmd_logfile; /* if --logfile was set */
+extern char *interface; /* interface required specification */
+extern char *cmd_interface; /* if --interface was set */
+extern char *monitor; /* monitored interface for activity */
+extern char *cmd_monitor; /* if --monitor was set */
/* these get computed */
extern int batchlimit; /* if --batchlimit was set */
@@ -201,6 +205,10 @@ int daemonize(const char *, void (*)(int));
int prc_parse_file(const char *);
int prc_filecheck(const char *);
+void interface_parse(void);
+void interface_note_activity(void);
+int interface_approve(void);
+
char *getpassword(char *);
void escapes(const char *, char *);
diff --git a/rcfile_l.l b/rcfile_l.l
index 24c027e8..b360e7fd 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -23,6 +23,8 @@ set { return SET; }
batchlimit { return BATCHLIMIT; }
fetchlimit { return FETCHLIMIT; }
logfile { return LOGFILE; }
+interface { return INTERFACE; }
+monitor { return MONITOR; }
defaults { return DEFAULTS; }
server { return POLL; }
poll { return POLL; }