aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS25
-rw-r--r--README3
-rw-r--r--fetchmail.man2
-rw-r--r--uid.c18
5 files changed, 21 insertions, 29 deletions
diff --git a/Makefile.in b/Makefile.in
index 755a8d87..3c96fd98 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -240,7 +240,7 @@ extra = $(srcdir)/alloca.c $(srcdir)/getopt.[ch] $(srcdir)/getopt1.c \
$(srcdir)/md5c.c
docs = $(srcdir)/COPYING $(srcdir)/FEATURES $(srcdir)/fetchmail-features.html \
$(srcdir)/design-notes.html $(srcdir)/NOTES \
- $(srcdir)/INSTALL $(srcdir)/NEWS $(srcdir)/README \
+ $(srcdir)/INSTALL $(srcdir)/NEWS $(srcdir)/TODO $(srcdir)/README \
$(srcdir)/README.NTLM $(srcdir)/fetchmail.lsm $(srcdir)/sample.rcfile \
$(srcdir)/*.man $(srcdir)/FAQ $(srcdir)/fetchmail-FAQ.html
config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/configure \
diff --git a/NEWS b/NEWS
index 46c9bd80..efea1ae6 100644
--- a/NEWS
+++ b/NEWS
@@ -1,33 +1,10 @@
- Things to do:
-
-In the SSL support, we need to add server certificate validation (In
-other words, does the certificate match the system we are trying to
-contact?). Also, add authentication of Certifying Authority (Is this
-a Certifying Authority we recognize?).
-
-Jorge Godoy asked, about the MD5 sums: Are they on the RPMs? How about
-using GPG/PGP instead of MD5 to sign the packages? If people are
-worried with copies of it, GPG/PGP offers more security than MD5. I
-don't know exactly, but I think you can sign it both ways so that your
-package will have two security verifications instead of one...
-
-Laszlo Vecsey writes: I believe qmail uses a technique of writing
-temporary files to nfs, and then moving them into place to ensure that
-they're written. Actually a hardlink is made to the temporary file and
-the destination name in a new directory, then the first one is
-unlinked.. maybe a combination of this will help with the fetchmail
-lock file
-
-The Debian bug-tracking page for fetchmail is:
-
- http://cgi.debian.org/cgi-bin/pkgreport.cgi?archive=no&pkg=fetchmail
-
Release Notes:
(The `lines' figures total .c, .h, .l, and .y files under version control.)
* Attempted fix for Joop Susan's ENOTCONN bug.
* Fix for NO response during SIZE fetches for M$ Exchange IMAP server.
+* Thomas Zajic <zlatko@gmx.at> sent a change that copes with GMX X-UIDLs.
fetchmail-5.2.7 (Sun Feb 6 20:45:41 EST 2000), 18517 lines:
* Updated FAQ.
diff --git a/README b/README
index c74dc57f..41cc71ab 100644
--- a/README
+++ b/README
@@ -27,7 +27,8 @@ run under AmigaOS.
Fetchmail is Y2K safe.
See the distribution files FEATURES for a full list of features, NEWS
-for detailed information on recent changes and NOTES for design notes.
+for detailed information on recent changes, NOTES for design notes, and
+TODO for a list of things that still need doing.
The fetchmail code appears to be stable and free of bugs affecting
normal operation (that is, retrieving from POP3 or IMAP in single-drop
diff --git a/fetchmail.man b/fetchmail.man
index 94cb377d..329d864e 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -1928,7 +1928,7 @@ In a message with multiple envelope headers, only the last one
processed will be visible to fetchmail. To get around this, use a
mailserver-side filter that consolidates the contents of all envelope
headers into a single one (procmail, mailagent, or maildrop can be
-orogrammed to do this fairly easily).
+programmed to do this fairly easily).
.PP
Use of any of the supported protocols other than POP3 with OTP or RPA,
APOP, KPOP, IMAP-K4, IMAP-GSS, IMAP-CRAMMD5, or ETRN requires that the
diff --git a/uid.c b/uid.c
index 9017ebbd..e5abda1a 100644
--- a/uid.c
+++ b/uid.c
@@ -124,12 +124,26 @@ void initialize_saved_lists(struct query *hostlist, const char *idfile)
/* first, skip leading spaces */
user = buf + strspn(buf, " \t");
- /* First, we split the buf into a userhost part and an id part */
- if ((id = strchr(user, '<')) != NULL ) /* set pointer to id */
+ /*
+ * First, we split the buf into a userhost part and an id
+ * part ... but id doesn't necessarily start with a '<',
+ * espescially if the POP server returns an X-UIDL header
+ * instead of a Message-ID, as GMX's (www.gmx.net) POP3
+ * StreamProxy V1.0 does.
+ */
+ if ((id = strchr(user, ' ')) != NULL )
{
for (delimp1 = id; delimp1 >= user; delimp1--)
if ((*delimp1 != ' ') && (*delimp1 != '\t'))
break;
+
+ /*
+ * It should be safe to assume that id starts after
+ * the " " - after all, we're writing the " "
+ * ourselves in write_saved_lists() :-)
+ */
+ id = id + strspn(id, " ");
+
delimp1++; /* but what if there is only white space ?!? */
saveddelim1 = *delimp1; /* save char after token */
*delimp1 = '\0'; /* delimit token with \0 */