aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac4
-rw-r--r--strlcat.c25
-rw-r--r--strlcpy.c25
4 files changed, 3 insertions, 53 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a1f261c..4a11ea99 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,7 +78,7 @@ DISTDOCS= BUGS FAQ FEATURES NOTES OLDNEWS fetchmail-man.html \
distdirs = rh-config contrib beos
EXTRA_DIST= $(DISTDOCS) fetchmail.spec $(distdirs) ucs/README.svn \
- trio/CHANGES trio/README
+ trio/CHANGES trio/README strlcpy.3
FAQ: fetchmail-FAQ.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; }
diff --git a/configure.ac b/configure.ac
index c7cfc9d4..82d3c9ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_INIT([fetchmail],[6.2.6-pre4])
+AC_INIT([fetchmail],[6.2.6-pre5])
AC_CONFIG_SRCDIR([fetchmail.h])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_LIBOBJ_DIR([.])
@@ -101,7 +101,7 @@ dnl Port hack for Sparc/NetBSD-1.5
AC_CHECK_LIB(intl, gettext,
[LIBS="$LIBS -lintl"])
-AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy])
+AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat])
AC_CHECK_FUNC(MD5Init, [],
[AC_LIBSOURCE(md5c.c)
diff --git a/strlcat.c b/strlcat.c
index db9d43c2..7b9673f9 100644
--- a/strlcat.c
+++ b/strlcat.c
@@ -17,28 +17,10 @@
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
*/
-#if HAVE_NBTOOL_CONFIG_H
-#include "nbtool_config.h"
-#endif
-
-#include <sys/cdefs.h>
-#if defined(LIBC_SCCS) && !defined(lint)
-__RCSID("$NetBSD: strlcat.c,v 1.16 2003/10/27 00:12:42 lukem Exp $");
-#endif /* LIBC_SCCS and not lint */
-
-#ifdef _LIBC
-#include "namespace.h"
-#endif
#include <sys/types.h>
#include <assert.h>
#include <string.h>
-#ifdef _LIBC
-# ifdef __weak_alias
-__weak_alias(strlcat, _strlcat)
-# endif
-#endif
-
#if !HAVE_STRLCAT
/*
* Appends src to string dst of size siz (unlike strncat, siz is the
@@ -48,11 +30,7 @@ __weak_alias(strlcat, _strlcat)
* If retval >= siz, truncation occurred.
*/
size_t
-#ifdef _LIBC
-_strlcat(dst, src, siz)
-#else
strlcat(dst, src, siz)
-#endif
char *dst;
const char *src;
size_t siz;
@@ -62,9 +40,6 @@ strlcat(dst, src, siz)
size_t n = siz;
size_t dlen;
- _DIAGASSERT(dst != NULL);
- _DIAGASSERT(src != NULL);
-
/* Find the end of dst and adjust bytes left but don't go past end */
while (n-- != 0 && *d != '\0')
d++;
diff --git a/strlcpy.c b/strlcpy.c
index fab8dac7..64d9c575 100644
--- a/strlcpy.c
+++ b/strlcpy.c
@@ -17,28 +17,10 @@
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
*/
-#if HAVE_NBTOOL_CONFIG_H
-#include "nbtool_config.h"
-#endif
-
-#include <sys/cdefs.h>
-#if defined(LIBC_SCCS) && !defined(lint)
-__RCSID("$NetBSD: strlcpy.c,v 1.14 2003/10/27 00:12:42 lukem Exp $");
-#endif /* LIBC_SCCS and not lint */
-
-#ifdef _LIBC
-#include "namespace.h"
-#endif
#include <sys/types.h>
#include <assert.h>
#include <string.h>
-#ifdef _LIBC
-# ifdef __weak_alias
-__weak_alias(strlcpy, _strlcpy)
-# endif
-#endif
-
#if !HAVE_STRLCPY
/*
* Copy src to string dst of size siz. At most siz-1 characters
@@ -46,11 +28,7 @@ __weak_alias(strlcpy, _strlcpy)
* Returns strlen(src); if retval >= siz, truncation occurred.
*/
size_t
-#ifdef _LIBC
-_strlcpy(dst, src, siz)
-#else
strlcpy(dst, src, siz)
-#endif
char *dst;
const char *src;
size_t siz;
@@ -59,9 +37,6 @@ strlcpy(dst, src, siz)
const char *s = src;
size_t n = siz;
- _DIAGASSERT(dst != NULL);
- _DIAGASSERT(src != NULL);
-
/* Copy as many bytes as will fit */
if (n != 0 && --n != 0) {
do {