aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS1
-rw-r--r--configure.ac5
2 files changed, 3 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 763e4e6b..44e02b21 100644
--- a/NEWS
+++ b/NEWS
@@ -89,6 +89,7 @@ fetchmail-6.4.0 (not yet released):
## CHANGES
* fetchmail 6.3.X is unsupported.
* fetchmail now requires OpenSSL v1.0.1 or newer.
+* fetchmail now configures OpenSSL support by default.
* Fetchmail now supports --sslproto auto and --sslproto tls1+ (same as ssl23).
* --sslproto tls1.1+ and tls1.2+ are now supported for auto-negotiation with a
minimum specified TLS protocol version, and --sslproto tls1.1 and --sslproto
diff --git a/configure.ac b/configure.ac
index 71287701..d6f96c2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,8 +725,7 @@ AM_CONDITIONAL(KERBEROS_V4_ENABLE, test "$KERBEROS_V4" = 1)
AC_ARG_WITH(ssl,
[ --with-ssl=[DIR] enable SSL support using libraries in DIR],
[with_ssl=$withval],
- [with_ssl=no])
-test "$with_ssl" != "no" && AC_DEFINE(SSL_ENABLE,1,Define if you want SSL support compiled in)
+ [with_ssl=yes])
if test "$with_ssl" = "yes"
then
@@ -795,7 +794,7 @@ then
if test "$i" = "" ; then i="(none)" ; fi
AC_MSG_RESULT($i)
dnl XXX FIXME: use pkg-config if available!
- AC_DEFINE(SSL_ENABLE)
+ AC_DEFINE(SSL_ENABLE, 1, [Define if you want SSL support compiled in])
else
AC_MSG_WARN(Disabling SSL support.)
AC_MSG_WARN(Consider re-running configure --with-ssl.)