aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in3
-rw-r--r--fetchmail.h8
-rw-r--r--rcfile_l.l2
3 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index 92b9bd9a..5fb143ef 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -198,8 +198,7 @@ $(srcdir)/rcfile_l.c: $(srcdir)/rcfile_l.l
$(srcdir)/rcfile_y.c: $(srcdir)/rcfile_y.y
parser = $(srcdir)/rcfile_l.l $(srcdir)/rcfile_y.y
-headers = $(srcdir)/fetchmail.h $(srcdir)/socket.h $(srcdir)/poproto.h \
- $(srcdir)/smtp.h
+headers = $(srcdir)/fetchmail.h $(srcdir)/socket.h $(srcdir)/smtp.h
extra = $(srcdir)/alloca.c $(srcdir)/bzero.[ch] $(srcdir)/errorcodes \
$(srcdir)/getopt.[ch] $(srcdir)/getopt1.c $(srcdir)/md5*.[ch] \
$(srcdir)/strcasecmp.c $(srcdir)/strdup.c
diff --git a/fetchmail.h b/fetchmail.h
index b4391226..d1186803 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -11,7 +11,13 @@
***********************************************************************/
-
+/* constants designating the various supported protocols */
+#define P_AUTO 0
+#define P_POP2 2
+#define P_POP3 3
+#define P_IMAP 4
+#define P_APOP 5
+#define P_RPOP 6
/* definitions for buffer sizes -- somewhat arbitrary */
#define POPBUFSIZE 512 /* per RFC 937 */
diff --git a/rcfile_l.l b/rcfile_l.l
index 728c2800..30ce2978 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -15,7 +15,7 @@
***********************************************************************/
#include <config.h>
-#include "poproto.h"
+#include "fetchmail.h"
#include "rcfile_y.h"
int prc_lineno = 1;