aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS1
-rw-r--r--sink.c4
3 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index fe0cd9af..cdc91945 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.9.6
+VERSION = 5.9.7
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 39b01284..f23b7939 100644
--- a/NEWS
+++ b/NEWS
@@ -10,6 +10,7 @@
* UIDL bug fix by Matthias Andree.
* Use smtpaddress, if present, to set the return path on warning mail.
* Tell parser to object when SSL keyboard is used with SSL not compiled.
+* GSSAPI and ODMR fixes by Tom Hughes.
fetchmail-5.9.6 (Fri Dec 14 04:03:50 EST 2001), 21247 lines:
diff --git a/sink.c b/sink.c
index 0951e9ca..ffd7a1f9 100644
--- a/sink.c
+++ b/sink.c
@@ -143,7 +143,11 @@ int smtp_open(struct query *ctl)
/* return immediately for ODMR */
if (ctl->server.protocol == P_ODMR)
+ {
+ set_timeout(0);
+ phase = oldphase;
return(ctl->smtp_socket); /* success */
+ }
/* are we doing SMTP or LMTP? */
SMTP_setmode(ctl->listener);