aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--fetchmail.h4
-rw-r--r--stpcpy.c25
3 files changed, 30 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 730dad70..01ed7113 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,7 +101,7 @@ dnl Port hack for Sparc/NetBSD-1.5
AC_CHECK_LIB(intl, gettext,
[LIBS="$LIBS -lintl"])
-AC_REPLACE_FUNCS([strstr strcasecmp memmove])
+AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy])
AC_CHECK_FUNC(MD5Init, AC_DEFINE(HAVE_MD5,1,Define if you have md5 in libc),
[AC_LIBSOURCE(md5c.c)
diff --git a/fetchmail.h b/fetchmail.h
index b47d6293..07b7978b 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -686,6 +686,10 @@ char *strerror (int);
#endif
#endif
+#ifndef HAVE_STPCPY
+char *stpcpy(char *, const char*);
+#endif
+
#ifdef FETCHMAIL_DEBUG
#define exit(e) do { \
FILE *out; \
diff --git a/stpcpy.c b/stpcpy.c
new file mode 100644
index 00000000..a425da59
--- /dev/null
+++ b/stpcpy.c
@@ -0,0 +1,25 @@
+/*
+ stpcpy.c - a strcpy replacement that returns the position of the NUL char
+ Copyright (C) 2004 Matthias Andree
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+*/
+
+#include <string.h>
+
+char *stpcpy(char *dest, const char *src) {
+ strcpy(dest, src);
+ return strchr(dest, 0);
+}