aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in3
-rw-r--r--configure.in5
2 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 2061d5a6..ec51a21e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -32,13 +32,14 @@ LDEFLAGS = @LDEFLAGS@
INTLDEPS = @INTLDEPS@
INTLLIBS = @INTLLIBS@
INTLOBJS = @INTLOBJS@
+localedir = @LOCALE_DIR@
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
# See also `config.h'.
-DEFS = @DEFS@ @EXTRADEFS@
+DEFS = @DEFS@ @EXTRADEFS@ -DLOCALEDIR=\"$(localedir)\"
# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
defines = $(DEFS)
diff --git a/configure.in b/configure.in
index f01c8574..0056e45f 100644
--- a/configure.in
+++ b/configure.in
@@ -227,11 +227,6 @@ if test "$USE_NLS" = "yes"
then
echo 'Enabling internationalization support...'
POMAKE='$(MAKE) -C po'
- if test "x$prefix" != xNONE; then
- EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"$prefix/share/locale\"'"
- else
- EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"$ac_default_prefix/share/locale\"'"
- fi
else
echo 'Disabling internationalization support...'
POMAKE="@echo '(NLS support disabled)'; #"