aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--NEWS7
-rw-r--r--configure.ac12
3 files changed, 8 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index a8848b30..3947e84e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
smbtypes.h fm_getaddrinfo.c tls.c rfc822valid.c \
xmalloc.h sdump.h sdump.c x509_name_match.c \
- fm_strl.h
+ fm_strl.h md5c.c
if NTLM_ENABLE
libfm_a_SOURCES += ntlmsubr.c
endif
diff --git a/NEWS b/NEWS
index 118e1c10..922bf0f9 100644
--- a/NEWS
+++ b/NEWS
@@ -54,7 +54,12 @@ removed from a 6.4.0 or newer release.)
--------------------------------------------------------------------------------
-not yet released:
+fetchmail-6.3.20 (not yet released):
+
+# CHANGES
+* fetchmail now always uses its own MD5 implementation. The library and header
+ variants are too diverse, and we've been bitten before -- and configure
+ complains noisily on Cyrus-SASL's RFC1321 md5.h.
# TRANSLATION UPDATES
[ja] Japanese (Takeshi Hamasaki)
diff --git a/configure.ac b/configure.ac
index c1d450cd..d95784f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,7 @@ AC_TYPE_SIGNAL
AC_CHECK_HEADERS([unistd.h termios.h termio.h sgtty.h stdarg.h \
sys/itimer.h fcntl.h sys/fcntl.h memory.h sys/wait.h \
arpa/inet.h arpa/nameser.h netinet/in.h net/socket.h netdb.h \
- sys/select.h sys/socket.h sys/time.h langinfo.h md5.h])
+ sys/select.h sys/socket.h sys/time.h langinfo.h])
if test _$ac_cv_header_stdarg_h != _yes ; then
AC_MSG_WARN([stdarg.h is not defined. Unsupported configuration, proceed at your own risk.])
fi
@@ -171,16 +171,6 @@ dnl [LIBS="$LIBS -lintl"])
AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat])
-have_md5=no
-if test "$ac_cv_header_md5_h" != no ; then
- AC_SEARCH_LIBS(MD5Init, [md], [have_md5=yes])
-fi
-
-if test "$have_md5" != yes ; then
- AC_LIBSOURCE(md5c.c)
- EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"
-fi
-
AC_CHECK_FUNC(getopt_long, [],
[AC_LIBSOURCES([getopt.c, getopt1.c])
EXTRAOBJ="$EXTRAOBJ getopt.\$(OBJEXT) getopt1.\$(OBJEXT)"])