aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README11
-rw-r--r--configure.in2
-rw-r--r--driver.c7
-rw-r--r--fetchmail.c4
-rw-r--r--mxget.c5
-rw-r--r--socket.c7
6 files changed, 17 insertions, 19 deletions
diff --git a/README b/README
index fdd70467..9d7e697d 100644
--- a/README
+++ b/README
@@ -13,10 +13,13 @@ RPOP, APOP, KPOP, all flavors of IMAP (including IMAP4rev1 with
RFC1731 Kerberos v4 authentication), and ESMTP ETRN.
The fetchmail code was developed under Linux, but has also been
-extensively tested under 4.4BSD, AIX, Solaris and NEXTSTEP. It should be
-readily portable to other Unix variants (it uses GNU autoconf). It
-has also been ported to QNX; to build under QNX, see the header
-comments in the Makefile. It is reported to build and run under AmigaOS.
+extensively tested under 4.4BSD, AIX, HP-UX versions 9 and 10,
+SunOS, Solaris, NEXTSTEP, OSF 3.2.
+
+It should be readily portable to other Unix variants (it uses GNU
+autoconf). It has also been ported to QNX; to build under QNX, see
+the header comments in the Makefile. It is reported to build and run
+under AmigaOS.
See the distribution files FEATURES for a full list of features, NEWS
for detailed information on recent changes and NOTES for design notes.
diff --git a/configure.in b/configure.in
index 385292b3..698fc1e9 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ AC_HEADER_STDC
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_TYPE_SIGNAL
-AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h sys/itimer.h fcntl.h sys/fcntl.h)
+AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h sys/itimer.h fcntl.h sys/fcntl.h memory.h)
AC_C_CONST dnl getopt needs this.
diff --git a/driver.c b/driver.c
index 949ef546..56046e16 100644
--- a/driver.c
+++ b/driver.c
@@ -11,6 +11,9 @@
#include <errno.h>
#include <ctype.h>
#include <string.h>
+#ifdef HAVE_MEMORY_H
+#include <memory.h>
+#endif /* HAVE_MEMORY_H */
#if defined(STDC_HEADERS)
#include <stdlib.h>
#endif
@@ -36,10 +39,6 @@
#include "mx.h"
#endif /* HAVE_GETHOSTBYNAME */
-#ifdef SUNOS
-#include <memory.h>
-#endif
-
#ifdef KERBEROS_V4
#if defined (__bsdi__)
#include <des.h> /* order of includes matters */
diff --git a/fetchmail.c b/fetchmail.c
index 883a1b8e..60b0ed17 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -33,10 +33,6 @@
#include <netdb.h>
#endif /* HAVE_GETHOSTBYNAME */
-#ifdef SUNOS
-#include <stdlib.h>
-#endif
-
#include "fetchmail.h"
#include "tunable.h"
#include "smtp.h"
diff --git a/mxget.c b/mxget.c
index 482ea568..726417b1 100644
--- a/mxget.c
+++ b/mxget.c
@@ -51,7 +51,8 @@ struct mxentry *getmxrecords(const unsigned char *name)
pmx->name = (char *)NULL;
pmx->pref = -1;
- n = res_search(name,C_IN,T_MX,(unsigned char*)&answer, sizeof(answer));
+ n = res_search((char *)name,
+ C_IN,T_MX, (unsigned char*)&answer, sizeof(answer));
if (n == -1)
return((struct mxentry *)NULL);
@@ -88,7 +89,7 @@ struct mxentry *getmxrecords(const unsigned char *name)
pmx[ind].pref = pref;
++ind;
- n = strlen(bp);
+ n = strlen((const char *)bp);
bp += n;
*bp++ = '\0';
diff --git a/socket.c b/socket.c
index ca4f0e16..d881498c 100644
--- a/socket.c
+++ b/socket.c
@@ -7,6 +7,9 @@
#include "config.h"
#include <stdio.h>
#include <string.h>
+#ifdef HAVE_MEMORY_H
+#include <memory.h>
+#endif /* HAVE_MEMORY_H */
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
@@ -35,10 +38,6 @@
#endif
#endif /* INET_ATON */
-#ifdef SUNOS
-#include <memory.h>
-#endif
-
int SockOpen(char *host, int clientPort)
{
int sock;