aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in7
-rw-r--r--configure.in10
2 files changed, 11 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 1faa4d1d..55139d95 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -22,6 +22,9 @@ YACC = @YACC@
# YACC = yacc
YACCFLAGS = -dt
+CEFLAGS = @CEFLAGS@
+LDEFLAGS = @LDEFLAGS@
+
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
@@ -101,14 +104,14 @@ all: fetchmail
.PHONY: all
fetchmail: $(objs)
- $(CC) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
+ $(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
# Tester for address parsing
rfc822: rfc822.c
gcc -DTESTMAIN -g rfc822.c -o rfc822
.c.o:
- $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $<
+ $(CC) $(defines) -c -I$(srcdir) -I. $(CEFLAGS) $(CFLAGS) $<
# For some losing Unix makes.
SHELL = /bin/sh
diff --git a/configure.in b/configure.in
index e8908274..9bdafd25 100644
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,8 @@ AC_C_CONST dnl getopt needs this.
AC_PROG_LEX
AC_PROG_YACC
+AC_SUBST(CEFLAGS)
+AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
# Under sysV68, socket and friends are provided by the C library.
@@ -169,16 +171,16 @@ AC_ARG_WITH(kerberos,
# configuring the BSD/OS Kerberos IV support, though.
if test -n "$with_kerberos"
then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I$with_kerberos"
- LDFLAGS="$LDFLAGS -L$dir/lib"
+ CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I$with_kerberos"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
else
for dir in /usr/kerberos /usr/kerberosIV /usr/athena
do
if test -f "$dir/include/krb.h"
then
- CFLAGS="$CFLAGS -DKERBEROS_V4 -I$dir/include"
- LDFLAGS="$LDFLAGS -L$dir/lib"
+ CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I$dir/include"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
LIBS="$LIBS -lkrb -ldes"
break
fi