aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in5
-rw-r--r--NEWS3
-rw-r--r--configure.in5
3 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index b73beac2..0d349fd0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -77,7 +77,7 @@ ETAGS = etags -tw
CTAGS = ctags -tw
protobjs = rcfile_y.o rcfile_l.o socket.o getpass.o pop2.o pop3.o imap.o \
- etrn.o fetchmail.o env.o options.o daemon.o smtp.o driver.o rfc822.o \
+ etrn.o fetchmail.o env.o options.o daemon.o driver.o rfc822.o smtp.o \
xmalloc.o uid.o mxget.o md5c.o md5ify.o interface.o netrc.o base64.o \
error.o
@@ -108,7 +108,7 @@ rfc822: rfc822.c
gcc -DTESTMAIN -g rfc822.c -o rfc822
.c.o:
- $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $< $(OUTPUT_OPTION)
+ $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $<
# For some losing Unix makes.
SHELL = /bin/sh
@@ -247,4 +247,3 @@ rpm: dist
cp $(RPMROOT)/SRPMS/fetchmail-$(VERS)*.src.rpm $(srcdir)
# Automatically generated dependencies will be put at the end of the makefile.
-# DO NOT DELETE THIS LINE -- makedepend depends on it.
diff --git a/NEWS b/NEWS
index eb151d6e..2b082481 100644
--- a/NEWS
+++ b/NEWS
@@ -22,8 +22,9 @@
fetchmail-4.0.6 ()
* Changed semantics of `via' and `poll <name>' to be more orthogonal.
* Substantially improved option coverage on the man page.
+* Yet another try at getting the remote-build right for Harry McGavran.
-WARNING: If you are running multidrop, READ FAQ ITEM F1 NOW!
+WARNING: If you are running multidrop, (RE)READ FAQ ITEM F1 NOW!
There are 255 people on the fetchmail-friends list.
fetchmail-4.0.5 (Wed Jul 30 10:27:25 EDT 1997)
diff --git a/configure.in b/configure.in
index f74123f3..db6e846d 100644
--- a/configure.in
+++ b/configure.in
@@ -157,8 +157,11 @@ else
fi
AC_OUTPUT(Makefile, [
+ # The reason for this odd makedepend line is that we want
+ # to have all dependencies evaluated relative to the source directory
+ # and let VPATH do all the dirty work when we build remotely
echo "You can ignore any makedepend error messages";
- makedepend -I$srcdir -I. -fMakefile ${srcdir}/*.c])
+ (cd $srcdir; makedepend -f - *.c) >>Makefile])
dnl Local Variables:
dnl comment-start: "dnl "