aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS2
-rw-r--r--driver.c1
2 files changed, 2 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index f0105047..3b4c5564 100644
--- a/NEWS
+++ b/NEWS
@@ -78,6 +78,8 @@ fetchmail 6.3.0 (not yet released officially):
* configure.ac cleanups by Miloslav Trmac (Matthias Andree)
* Miloslav Trmac's fix to reply_hack() type, for systems where
sizeof(int) != sizeof(size_t). (Matthias Andree)
+* Nalin Dahyabhai's fix for driver.c to not call the private Kerberos
+ krb5_init_ets() function. Sent by Miloslav Trmac. (Matthias Andree)
fetchmail-6.2.5 (Wed Oct 15 18:39:22 EDT 2003), 23079 lines:
diff --git a/driver.c b/driver.c
index 008a7fa8..eb972bd9 100644
--- a/driver.c
+++ b/driver.c
@@ -211,7 +211,6 @@ const char *canonical; /* server name */
krb5_auth_context auth_context = NULL;
krb5_init_context(&context);
- krb5_init_ets(context);
krb5_auth_con_init(context, &auth_context);
if (retval = krb5_cc_default(context, &ccdef)) {